• I am embedding forms using the shortcode but my frontend is not showing the forms. It was working fine till a few days back.
    Eg. Shortcode – [ultimatemember form_id=”296″] is not displaying anything. I have cleared my cache as well, but the form is still not displayed.

    I recently updated to WordPress 5.5 and have Ultimate Member 2.1.7
    Not sure if it has anything to do with the updates.

    I also checked shortcodes of other plugins and they are working fine.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter karan1977

    (@karan1977)

    I have found something strange on further investigation.

    When the page that contains the shortcode loads, it does not show the form.
    But, when I right click and select “Inspect” the whole form suddenly shows up!
    This is happening in Chrome as well as Edge browsers

    Thread Starter karan1977

    (@karan1977)

    I can also confirm that after downgrading to WordPress 5.4.2 and ultimate member v2.1.6 the forms are appearing on page load.

    Same issue here – following.
    Weirdly, we can view others’ profiles while logged in, but the public can’t see the forms.
    Using Firefox, and WP 5.4.2. I’ve done a theme and plugin conflict test already.

    Update: I’ve inserted the forms using the UM Gutenburg ‘block’ (UM Form) and it seems to resolve the issue. I.e. it’s the shortcode themselves that aren’t being processed (or whatever the applicable term is).

    I have re-updated Ultimate Member to 2.1.7 and all looks good. (Note: We’ve not upgraded to WP5.5 due to a clash between Ultimate Member and our theme)

    • This reply was modified 1 year, 11 months ago by lauramay7. Reason: added version data

    My login form was not showing up with WP5.5 and UM 2.1.7 (or 2.1.6).

    From @karan1977
    “When the page that contains the shortcode loads, it does not show the form.
    But, when I right click and select “Inspect” the whole form suddenly shows up!”

    That is interesting; it also happens in Firefox. I’ll have to try using the Gutenburg block.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Shortcodes not working’ is closed to new replies.