Support » Plugin: Post Snippets » shortcodes not translated

  • I have two WordPress installs. Both are running WP 4.7.2

    One is running Twenty-Seventeen.
    One is running Twenty-Fourteen.

    Both have Post Snippets installed.

    The site running Twenty-Fourteen works as expected.
    The site running Twenty-Seventeen displays [shortcode-name] instead of translating the shortcode.

Viewing 4 replies - 1 through 4 (of 4 total)
  • I think you have to “activate” the shortcode in Post Snippets. 🙂

    I have checked the shortcode box for the snippet I wish to insert. The shortcode is inserted when I pick the Post Snippet in the editor.

    I can find no place where I can control whether shortcodes are translated. The published page shows the shortcode and not information I want to display.

    hmmmm…I took a look at my own Post Snippets set-up.
    There isn’t an “activation” button…I was thinking of wp-snippets plugin. Sorry on that one.
    In Post Snippets, I remember having the same issue if:

    1- I had <?php ?> enclosing the snippet code when I pasted it into the box in Post Snippets.

    2- I improperly set the checkboxes for the snippet in Post Snippets.

    You could test the theme by doing the shortcode “the hard way” by putting your snippet in your functions.php file and add “shortcode(‘shortcode name’, ‘function name’)” beneath it. I presume you know how 🙂 If not, see shortcode in the codex.

    Then test and see if it works. If you do that correctly and it works, then the problem is with the checkbox/snippet code for the snippet in Post Snippets.

    I seriously doubt it has anything to do with the difference in theme.

    Also, load up twenty-fourteen in the problem site and activate it without changing anything in Post Snippets. Most likely it won’t work with ’14 either. Pointing again to something with checkboxes/code in the Post Snippets shortcode entry.

    And of course check spelling of shortcode in both places 🙂 I have suffered over a misplaced letter for hours before while chasing other possible causes 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘shortcodes not translated’ is closed to new replies.