Support » Plugin: Events Manager » Shortcodes aren't working after upgrade to 4.4

Viewing 13 replies - 1 through 13 (of 13 total)
  • I have upgrade wordpress 4.4. The shortcode [event_form] is not working. The form appears but when you feel the details, The event entry does not appear admin side..

    Shortcode :

    [event_form]

    This is across all of wordpress, not just this plugin. Have no idea what these folks were things. Hundreds and hundreds of plugins using shortcodes and they’re all broken now. Read somewhere its because they don’t accept spaces anymore. Absolutely moronic of them to do this.

    Plugin Support caimin_nwl

    (@caimin_nwl)

    NetWebLogic Support

    @ggower Does it work if you test with a default WordPress theme?

    @maulikparekh Which version of Events Manager are you using?

    @peteratomic Can you post link? I think you may be thinking of changes that were proposed but are still being discussed…

    @caimin_nwl : Hello I am using events manager plugin version 5.6.1 with wordpress version 4.4

    Problem has been solved – it was a matter of manually re-typing the shortcode in “text” view, and now it works.

    Plugin Support caimin_nwl

    (@caimin_nwl)

    NetWebLogic Support

    @ggower Thanks for the update, might help someone else.

    @maulikparekh Can you try @ggower‘s suggestion of re-typing the shortcode?

    @caimin_nwl : I have tried manually re-typing the shortcode in “text” view, but it doesn’t work for me. I have also tried <?php em_event_form(); ?> shortcode in php file. it also doesn’t work..Form appears but when you fill the details, there is no entry in admin event side in wordporess 4.4

    Plugin Support caimin_nwl

    (@caimin_nwl)

    NetWebLogic Support

    @maulikparekh So the form is now appearing on the page but the submission process isn’t working?

    Patrick Steil

    (@patrickchurchbuzzorg)

    I have seen similar problems on a standalone WP site with one plugin and on a WPMU site with a different plugin. There are also reports of this randomly happening on Google.

    This seems to be a problem with WP 4.4 somehow, but doesn’t affect all plugins/shortcodes somehow.

    I have tried the method of just re-typing in the shortcode and this didn’t work for me.

    Anyone on this thread a WP core dev?

    I am available to help debug this – contact me at patrick@churchbuzz.org – thanks!

    @caimin_nwl I have re-tested by retyping the shortcode [event_form]. it works now but only when the user is log out. When the user is logged in the event entry does not appear in the event list in admin side. When the user is logged out, Everything works fine.

    I had a similar issue which I thought it was related to shortcodes
    Ended up being the_content() method not returning anything even though the post was declared
    I fixed it by adding this line just before
    if (have_posts()) the_post();

    Plugin Support caimin_nwl

    (@caimin_nwl)

    NetWebLogic Support

    If anyone is still having problems, can you make sure you’re using the latest version of the plugin released earlier today? This should fix the the problem.

    i am still having this problem with ALL EM shortcodes.

    also, i get zero print-out with shortcodes alone, and if i put “CONTENTS” on the page, i can see the shortcode itself… but no Contents whatsoever…

    this is now WP 4.5.1 with the latest EM version(5.6.4)… i also uninstalled latest and reinstalled 2 versions previous (5.6.3 & 5.6.2) – this did not help.

    i think, for me, its a server issue because i am running the same combination on another server and it works just fine… i don’t know enough to know what’s different on the servers…

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Shortcodes aren't working after upgrade to 4.4’ is closed to new replies.