WordPress.org

Support

Support » Themes and Templates » [Resolved] Shortcodes are not working

[Resolved] Shortcodes are not working

Viewing 4 replies - 1 through 4 (of 4 total)
  • client153182
    Member

    @client153182

    I’ve got exactly the same problem. Did you managed to get this resolved

    Sovit
    Member

    @sovitranjitkar

    Hi vili_banilly and client153182,

    It seems the theme you were using before provided the shortcodes. If you switch your theme the shortcode provided by your previous theme will not work on our theme because they were hardcoded in your previous theme. Whether you use our theme our any other theme from WordPress.org the shortcodes will not work. Hardcoding any shortcodes as your previous theme does is a bad practice which makes user locked-in to their theme. And whenever you try to change the theme the output breaks. But if the shortcodes you are trying to use is provided by plugin then check whether the plugin it is activated or not.

    Thank you !

    Hi Sovit,

    I’m having the same problem as op. For example, I am using contact form 7 on a page. When I post the shortcode it does not work (instead it just displays the shortcode itself on the page).
    If I use exactly the same shortcode on a post it works fine.

    Is there something in your theme that is disabling shortcode usage on pages?

    I have tried several other contact forms and they don’t work either.

    Any help much appreciated!

    Hi

    I have half answered my own question above.

    The shortcode does work on pages but only when you have “Default Template” selected. It does not work on “Corporate Template”. Is this an easy fix? I’ll try and work it out myself but feel free to post the answer here! 🙂

    Thanks

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] Shortcodes are not working’ is closed to new replies.