Support » Plugin: Compact WP Audio Player » Shortcode to habe On Home Page only does not work

  • Michael Lanfield

    (@michaellanfield)



    Hi. Thank you creating a great plugin. You should have a feature to add more audio files one after the other with a forward button. Otherwise, I’ve added the code to the home page via footer widgets/sidebar, but it is playing on every page. I tried adding this code with my mp3 url and it says there are 2 errors when I implement the code you provide. So I cannot save it. Help.

    <?php
    if(is_front_page()){
    echo do_shortcode(‘[sc_embed_player fileurl=”Uhttps://www.thosecrazyvegans.net/wp-content/uploads/2017/11/official_website.mp3″ autoplay=”true”]’);
    }
    ?>

    Here is a screenshot of the issue.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, try by removing the following character U from the fileurl=”” parameter.

    From

    fileurl=”Uhttps://www.thosecrazyvegans.net/wp-content/uploads/2017/11/official_website.mp3″

    to

    fileurl=”https://www.thosecrazyvegans.net/wp-content/uploads/2017/11/official_website.mp3″

    Let me know if this works.

    Thank you

    Michael Lanfield

    (@michaellanfield)

    hi. Thank you. The short code does not seem to work on my macbook pro either Safari or Safari browsers.

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, did you make the changes I suggested above? Did you also clear your cache if you have a cache plugin installed?

    If the code does not work when you added it to your theme, can you test one of WordPress default themes like Twenty Sixteen or Seventeen?

    Thank you

    Michael Lanfield

    (@michaellanfield)

    This is the whole code I’ve added to the widget area at the footer. It doesn’t seem like it is playing at all on the new firefox browser.

    <center><a href="https://www.thosecrazyvegans.net/going-vegan">
    <img src="
    	https://www.thosecrazyvegans.net/wp-content/uploads/2017/11/shopedit.png" alt="Why Vegan ThoseCrzyVegans.net"></a></center>
    <center>[sc_embed_player autoplay=true fileurl=”https://www.thosecrazyvegans.net/wp-content/uploads/2017/11/official_website.mp3″]</center>
    Michael Lanfield

    (@michaellanfield)

    tried 2016 and 2017 theme and 2016 theme. Not working. Firefox browser 57. Even cleared the cache and have hard refresh for firefox.And even disabled all the plugins.

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, just looking at your code make sure you are using the double quotes correctly. For example “”.

    Make sure you are using the correct double quotes.

    fileurl="https://www.thosecrazyvegans.net/wp-content/uploads/2017/11/official_website.mp3"

    If the above does not help. Can you disable all other plugins except this one, then carry out a test? What happens then?

    • This reply was modified 11 months ago by  mbrsolution.
    • This reply was modified 11 months ago by  mbrsolution.
Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Shortcode to habe On Home Page only does not work’ is closed to new replies.