Support » Plugin: Gutenberg » Shortcode to carousel slider

  • Resolved grindstr

    (@grindstr)


    Hi!
    I have started working with Gutenberg and get more used to it every day. But I have a problem when using shortcode to some slider gallery that I like to use.
    It works ok adding slider on the specific post site, like this one
    https://solnikgarden.com/byala-11-7-18/
    but not on the main post side https://solnikgarden.com/post/page/2/.
    You have to scroll down a little, the you see vertical presentation of every pictures. Selecting one of the pictures just open the picture in the browser.

    regards
    grindstr

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator Marius L. J.

    (@clorith)

    Hi,

    Is this behavior you are seeing without Gutenberg as well?

    To me this looks like the slider plugin does not load its code on archive pages, which isn’t unlikely as many archive pages strip away shortcodes.

    If it doesn’t happen normally, would you be able to share what plugin it is so we can have a look?

    Thread Starter grindstr

    (@grindstr)

    Hi!
    Thanks for looking in to this. The answer is no. I turn both main post site an post article to classic, then everything work normal. The slider work in both places.
    Take a look at my test site https://ecotechbio.com/solnikfarming/post-classic/

    The slider plugin is Carousel Slider Version 1.8.9 | By Sayful Islam.

    grindstr

    Moderator Marius L. J.

    (@clorith)

    Hi,

    Sorry about the delayed response, weekend and the likes πŸ™‚

    I’ve had a test of the plugin, and I can’t make it work as you expect neither with or without Gutenberg activated.

    It’s worth noting that I checked into it, and the plugin is not actually coded to work on archive pages like you want.
    The author does have solution to this though, covered in the following forum post https://wordpress.org/support/topic/not-initializing-on-homepage-posts/

    Thread Starter grindstr

    (@grindstr)

    Hi and thanks Marius!
    I put the code in function.php and then it works.
    I’m not that into coding, but it’s strange it worked in my test environment without this code?
    But anyway, as long as the it works, everything is ok.
    Thanks for looking into this and to great help.

    grindstr

    Moderator Marius L. J.

    (@clorith)

    You might have used their widget somewhere on your site on your test site? That would load the styles etc outside of single posts as well then πŸ™‚

    Glad to hear you got it all working!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Shortcode to carousel slider’ is closed to new replies.