WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Shortcode not working the same as script?

[Resolved] Shortcode not working the same as script?

  • Hi, I’m having a bit of trouble getting shortcode to act the same as WPPA script. The script I’m using is:

    %%wppa%%
    %%album=$Matilda W%%

    Which works fine – as expected, it shows a list of thumbnail links to the pictures.

    However, when I tried to translate that to shortcode and wrote this:

    [wppa type=”album″ album=”$Matilda W″ ][/wppa]

    The display is now the album cover with the “Slideshow” and “View 11 Photos” links.

    I’ve double- and triple-checked the documentation and as far as I can tell the shortcode I’ve written should be equivalent to the script. Can you tell me what I’ve done wrong?

    http://wordpress.org/extend/plugins/wp-photo-album-plus/

Viewing 2 replies - 1 through 2 (of 2 total)
  • I just checked it, but it should work as you expect.
    Maybe there is a problem with the quotes if you typed it manually in the visual editor, so that type=”album” is not properly understood.

    Please try the shortcode generator as described here

    You were exactly right – the quote characters somehow ended up being the Unicode open/close double-quote chars, instead of the standard ASCII double-quote.

    Thanks for the help, much appreciated 🙂

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] Shortcode not working the same as script?’ is closed to new replies.