Support » Plugin: immonex Kickstart » Shortcode not working [inx-filters-sort] in Divi Layout

  • Hello there!
    I am seeing the same issue as someone else in another thread: the sort shortcode isn’t working in my divi (theme builder) layouts.

    The other person was able to fix this issue by inserting the shortcode in a gutenberg block.
    However this is not an option in this setup, as all pages are built with Divi Builder and neither Gutenberg nor Classic Editor are in use.

    Any idea how to solve this?

    Thanks so much in advance! I will code dive in the meantime, but still hoping that there is an easy fix, so I dont have to code :D:D

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author immonex


    Hi Saskia!

    Two quick questions:

    Is the “Dynamic Updates” option enabled under immonex > Settings > Property Search?

    What happens on changing the sort order in the frontend? Does the page/list content get updated, but not sorted accordingly?

    Thread Starter Saskia Lund


    Hello @immonex !

    1. Dynamic updates is enabled in plugin settings
    2. Nothing is happening basically:
    I used the default attribute as well in sort shortcode, but the list also doesn’t get sorted on first load, even though the sort select menu displays “Price desc”..

    I found out that the only way to make it at least sort the list, is by adding the target CSS ID selector, which is by default inx-property-list.
    However instead of doing an ajax request without page reload, it trigger a page reload, once a new sort option has been picked.

    Same goes for the filter shortcode. I must add the dynamic update attribute to the shortcode with the list’s id in it. However, filtering only works after ticking the Filter button and after page reload.

    And another issue I have noticed with the filter shortcode:
    when it is placed on a taxonomy archive, let’s say locations, then it will always display the total number of objects, instead only the number of objects in the current loop of the locations page. The listing shortcode however outputs only the corresponding objects, as desired.

    Thanks for your quick reply!

    Plugin Author immonex


    Ok, let’s tackle this step by step:

    Basically, the attributes of the filters/sort shortcode do not directly influence the list view. So if the properties are to be sorted in descending order of price, this must be stated in both shortcodes:

    [inx-filters-sort default="price_desc"]
    [inx-property-list sort="price_desc"]

    Beyond that, there was an issue regarding an unintended page reload on changing the sort order if the dynamic-update attribute of the search form shortcode was – as in your case – manually set and only included the DOM ID of the property list element. This has been fixed in the current beta version 1.6.7 (available at But if you just remove this attribute from the list shortcode, it should also work (without page reload).

    With the current beta, we could not reproduce the count issue on the archive pages spontaneously. Could you please provide an example URL? (Just mail it to if it’s a site that is not publicly available.)

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Shortcode not working [inx-filters-sort] in Divi Layout’ is closed to new replies.