WordPress.org

Support

Support » Plugins and Hacks » Bottom of every post » [Resolved] Shortcode not working?

[Resolved] Shortcode not working?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Corey Salzano

    @salzano

    There is no call to execute shortcodes on the message content. You could hack it in if you want this behavior. I am never going to publish another update to this plugin, so you don’t have to worry about an update crushing your customizations.

    http://codex.wordpress.org/Function_Reference/do_shortcode

    jamiek47

    @jamiek47

    Hi Corey,

    Thanks for getting back to me although you don’t support this any more 🙁

    So I just need to add the code.

    <?php echo do_shortcode( $content ) ?>

    Where should I add it?

    Appreciated!

    Plugin Author Corey Salzano

    @salzano

    There’s no reason for me to update the plugin. Nearly every user customizes it like you are about to do yourself, and updates break those changes.

    Change line 43:

    return $content . do_shortcode( stripslashes( $msg ));

    jamiek47

    @jamiek47

    Thanks for helping out Corey I appreciate it.

    I added the code but the short code is just displaying as text at the bottom of the post.

    Any ideas why?

    Cheers

    jamiek47

    @jamiek47

    Ok I got it working, its just one of the plugins shortcode doesn’t work!

    Thanks Corey.

    Hi Corey

    Thanks. Let me confirm:

    I need to add the following to your plugin?

    <?php echo do_shortcode( $content ) ?>

    and

    Change line 43:

    return $content . do_shortcode( stripslashes( $msg ));

    Plugin Author Corey Salzano

    @salzano

    The only change required is line 43.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Shortcode not working?’ is closed to new replies.
Skip to toolbar