Support » Plugin: Zotpress » Shortcode make page not loading or editing

  • Resolved orion42

    (@orion42)


    If the plugin is active, the page is not loading properly: menu and admin bar on top of the page do not load at all, and instead of the page content this error appear:

    ‘{“status”:”empty”,”instance”:”zotpress-f1e653be466f6777b2d03842c82e763f”,”meta”:{“request_last”:0,”request_next”:0},”data”:”0″}’

    The same error on a blank page appears if you try to edit the page from the dashboard:
    This is the entire html of the resulting page:

    ‘<html class=”gr__eeg_zoo_cam_ac_uk”><head><style type=”text/css” id=”ctre_styles”>
    …</style></head><body data-gr-c-s-loaded=”true” class=”vsc-initialized”>{“status”:”empty”,”instance”:”zotpress-f1e653be466f6777b2d03842c82e763f”,”meta”:{“request_last”:0,”request_next”:0},”data”:”0″}</body></html>’

    This is the original shortcode
    [zotpress author=”Michela Leonardi” sortby=”date” order=”desc” highlight=”Leonardi, M.” download=”yes”]

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Katie

    (@kseaborn)

    At first, I had the same problem. I identified one bug which cancels loading of the page if there’s an error. The source of the bug, for me, was the quotations in the shortcode. This has been reported a few times now. Instead of plain quotations, there’s special styled ones in the shortcode. Can you try re-typing the quotations? (Unfortunately, WP seems to translate plain quotations into styled ones as well, so you’ll have to do it manually in your page/post.)

    Plugin Author Katie

    (@kseaborn)

    By the way, I’ve implemented somewhat of a fix for this, but there’s a special case when names/words with multiple parts (with a space between them) are used in the author or other fields. Basically, the shortcode parameter quotes are ignored and whatever follows after the equals sign is considered the value. But when there’s a space, that signals a new parameter. The only way around this is to use/re-type plain quotes around the parameter value (why are stylized ones appearing? Not sure yet … but may be the upgrade to Gutenberg and conversion of the editor to blocks, etc.).

    • This reply was modified 4 months, 2 weeks ago by  Katie.

    Thank you very much, it fixed the error. However, (before the fix) even with the classic editor I had the same issue, so I am not sure if it is linked to Gutenberg or to some other text/code filters.

    I think it is already been reported, but right now in all the pages on the site the citations are not in order and shown all starting with 1.

    • This reply was modified 4 months, 2 weeks ago by  orion42.

    Adding the style parameter solved my issue. However, I guess that as a default behaviour no numbers or ordered list should be displayed (instead of a list of 1.)

    Plugin Author Katie

    (@kseaborn)

    I also had it in the classic editor (and always had it set to HTML mode to get around this). Curious about the second issue … it’s fixed for 7.1.2, but I will check with the style parameter as well.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Shortcode make page not loading or editing’ is closed to new replies.