Support » Plugin: Insert or Embed Articulate Content into WordPress » Shortcode in Divi text block not displaying

  • Resolved Steve Covello

    (@weevie833)


    When I insert the shortcode into the Classic editor in WordPress, it works fine. But if I use the Divi Builder, create a row, add a Text block, and insert the shortcode using the “a” button, the content does not display.

    When I check the code in the Inspector (Chrome in both Windows and Mac), the content code is there, but it does not display. Any suggestions?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi Steve,

    Are you hitting Save Changes after you insert into the post? See about 35 seconds into this video:

    Thread Starter Steve Covello

    (@weevie833)

    I believe I did it properly – here is a screencast:

    http://www.kaltura.com/tiny/xts5y

    The funny part is that the media I am embedding has sound on the landing page and I can hear it, but I can’t see it. When I check the code in the browser, the content is there.

    Hi Steve,

    Yes, my plugin is working as expected. However, the row or column that you’re placing on the page isn’t viewable. For more information, see:

    https://360.articulate.com/review/content/00daebd7-fb85-4ff6-b115-da07c2ed8660/review

    So, you should be able to fix this by playing with your row & column settings in Divi.

    Thread Starter Steve Covello

    (@weevie833)

    Thanks for the screencast. I ended up moving the module that contained the shortcode to another location to see if the same problem would occur in a different Divi Builder row, and it worked. I can’t explain why, but it did. If I can narrow down the conditions for this visibility problem, I will post. Thanks for your help.

    Thread Starter Steve Covello

    (@weevie833)

    Solution: The row where I had posted the embed code had been designated to be visible only on mobile devices. Since it was viewed on a laptop browser, the device detection kicked in to place the content into visibility: hidden. Meanwhile, the content in the lower area for contact was designated to be visible to all devices. That is why one row was visible but the other was not. This was a Divi configuration problem that I had not noticed until digging deeply into the row settings.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Shortcode in Divi text block not displaying’ is closed to new replies.