Support » Plugin: DobsonDev Shortcodes » shortcode doesn’t work

  • Resolved lueromat

    (@lueromat)



    Hi Alex,

    I have been trying to embedd a readme from my github page on my personal homepage, but I can’t get it to work. I have deactivated all other plugins, still no success. I have been using this shortcode:

    [embedGitHubReadme owner=”mluerig” repo=”iso-cv”]

    Do you have any idea about what is wrong?

    Cheers
    Moritz

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author DobsonDev

    (@dobsondev)

    Hi Moritz,

    I just tested our your shortcode on my website and it worked, so I’m thinking it has something to do with your hosting maybe that isn’t allowing it to run the Markdown Library I use with the plugin. Do you happen to have access to your PHP error log or anything like that?

    You can view my working version here: https://dobsondev.com/testing-page/.

    • This reply was modified 5 months ago by  DobsonDev.
    lueromat

    (@lueromat)

    Hey Alex,

    thanks for the really quick reply. I have to set up my wordpress php error-log first – or could I retrieve it somehow from my hosting service?

    Moritz

    Plugin Author DobsonDev

    (@dobsondev)

    Yeah it depends on your hosting service how you would check it out. Often times there is a cPanel or something like that you can login to and then there’s an “Logs” section in there where you can view it.

    The library I’m using to parse the Markdown is called Parsedown (http://parsedown.org/) and it says that it’s been tested in PHP 5.3 to 7.1 so that shouldn’t affect it in any way.

    The other thing you might want to check is that your quotation marks are just regular quotation marks (not the kind with directions) and that your shortcode isn’t embedded in any code tags or anything. Sometimes if you copy paste from my examples it ends up doing weird things.

    If you want to make sure it doesn’t have the weird quotations or anything feel free to copy from this pastebin: https://pastebin.com/VaLdjVc9. It has just the regular quotations and copying from there should keep it that way.

    • This reply was modified 5 months ago by  DobsonDev. Reason: Added Pastebin link
    Plugin Author DobsonDev

    (@dobsondev)

    I’m going to mark this as resolved for now. If you find out more please just reply and we’ll keep looking at a solution!

    lueromat

    (@lueromat)

    I have set up my error log and tried to reproduce the error by using the shortcode and visiting the page, but the log remains empty. I also checked the logs at my hosting service, but they remain empty as well. I have sent you the regular log files via email.

    I have used the button provided on the editor, so the quotation marks are as they should.

    It suddenly started working after I edited the Readme.md on github. Could be that this was the source of error.

    Plugin Author DobsonDev

    (@dobsondev)

    Glad you found that – it’s odd though since I could get it to load before that but I’ll try to take a look into it when I have time and see. It could be you have some extra code in your Theme or something that required the edits to be made to the README file.

    I’m really happy you got it fixed though!

    uff, stopped working again, although I didn’t do anything to the readme on github – really strange. maybe that other issue I had yesterday with your plugin is also related to this: https://github.com/SufferMyJoy/dobsondev-shortcodes/issues/5

    great plugin though, for the short time it worked. it would be great if at some point you could find the time to look into this.

    Plugin Author DobsonDev

    (@dobsondev)

    Can you send me the link to the page where you are trying to link the shortcode so I can take a look there?

    I will definitely take a look at the Parsedown library and try to give it an update today to see if that works any better.

    I’ve updated the plugin to include the newest version of Parsedown. I’ve also taken a look and there is no additional parsing done by the plugin, I just retrieve the README file and then run it through Parsedown after it’s been run through base64_decode().

    Hopefully that will solve the problem. Let me know!

    • This reply was modified 4 months, 2 weeks ago by  DobsonDev. Reason: Updated the Plugin

    hey, thanks for having a look. unfortunately it still doesn’t work.
    This is the page where I embedded the link: http://luerig.net/computer-vision/
    and this is the repository: https://github.com/mluerig/iso-cv

    Plugin Author DobsonDev

    (@dobsondev)

    It looks like the page where you embedded the link just forwards to the repository now (I assume you did this since the pictures weren’t loading) so I can’t really take a look at see if anything is happening on the page.

    I’ve actually tried the shortcode out on some other sites I manage just to test it out and the pictures loaded on all of them. I even tried different hosting platforms just to be sure and still everything loaded, so it makes me think it had something to do with your host or one of the other plugins on the site. Have you tried disabling all the other plugins on the site and seeing if it works then?

    whoops, yes I did that a while ago, sorry. changed it back.
    yeah I did deactivate all other plugins, but this didn’t change anything. this indeed points towards my hoster as the source of error. it’s funny, a while ago it worked for a really brief moment (coinciding with some edits to the readme), but after a day or so it stopped. I might do some more research on that…

    nevermind that, I just tried another repository of mine (this one, just added another shortcode to the same page), and this works. it must be something in the markdown of that other readme that throws an error

    • This reply was modified 4 months, 2 weeks ago by  lueromat.
    Plugin Author DobsonDev

    (@dobsondev)

    Weird… I thought you said before that you had it working but then it stopped randomly after right? Maybe this one will do the same thing? It’s odd that it’s so hit or miss right now but I have a feeling it might be the hosting. I can’t think of what else it could be at this point.

    I will leave it as it is for now and get back to it every now and then to see if it still works. I will also check the repo that caused the problem in the first place when I have time to see if I can narrow down the cause. My feeling tells me it is because of the pictures, but I that’s a wild guess 🙂

Viewing 15 replies - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.