Support » Plugin: A-Z Listing » shortcode does not work

  • Hi!
    Can you help me because I can’t configure the plugin and it helps me a lot?
    I have on the site a category of products with 42 subcategories. There are several products in each subcategory. I created pages for all subcategories and tried all the options to put code, but nothing works, unfortunately.
    The slug for the main category is “avocati” and a subcategory has the slug “avocati-baroul-alba”
    I tried in the subcategory page to put [a-z-listing] , I put the same code in the dedicated field for codes in the template builder and it showed me all the articles on the site, not products.
    I tried [a-z-listing display=”terms” taxonomy=”product_category” parent-term=”26″] and all letters are unlinked.
    Also, [a-z-listing display=”posts” post-type=”product” taxonomy=”product_categories” terms=”avocati-baroul-alba”] , nothing…
    I’ma beginner. Please help me! Thanks!

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Daniel Llewellyn

    (@diddledan)

    Hi,

    WooCommerce product categories are in the taxonomy called product_cat, so you likely want a short code like this:

    [a-z-listing display="terms" taxonomy="product_cat" parent-term="26"]
    

    You might also want, depending on whether your categories are multiple-levels or not, to also add get-all-children="yes", which will show all descendants (children and their children etc) rather than just immediate children.

    Thread Starter infojuri

    (@infojuri)

    not working 🙁
    I tried all the options
    I also changed the page link to not be similar to the category slug. Before the link to the page was: https://infojurist.ro/avocati-baroul-alba/ and the category slug for which I want the terms to be displayed is “avocati-baroul-alba”

    now it looks like this with the letters without links : https://infojurist.ro/baroul-alba/

    Plugin Author Daniel Llewellyn

    (@diddledan)

    It looks like you don’t have WooCommerce enabled, so the product_cat taxonomy is not available. You likely meant to use a different taxonomy name.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘shortcode does not work’ is closed to new replies.