WordPress.org

Forums

I Recommend This
[resolved] Shortcode and Widget Not Working (7 posts)

  1. feshin
    Member
    Posted 1 year ago #

    I really love the simplicity of your plugin! I've manually added the code to my templates and voting works great. The only catch is that the shortcode and widget don't seem to be working for me.

    I've added the shortcode to a page, but it doesn't generate any code at all. The same with the widget.

    I'm using it on a multisite, but the plugin is only enabled on the main site. Any help would really be appreciated.

    Thanks!

    http://wordpress.org/plugins/i-recommend-this/

  2. feshin
    Member
    Posted 1 year ago #

    Ok - The widget IS working. My bad. I had a cache issue with it.

    However, the shortcode still doesn't seem to work.

    I've tried it as you specified on the plugin options page as well as without any options. I'm assuming both approaches work?

    [dot_recommended_posts container='div' post_type='showcase' number='10' year='2013' monthnum='7']
    
    [dot_recommended_posts]
  3. Harish Chouhan
    Member
    Plugin Author

    Posted 1 year ago #

    @feshin,

    I have not tested it on a WP network setup. So would need your help with testing. Can you please answer this:

    1. Is the shortcode placed on the main site of the network, where the plugin was activated?
    2. can you share the page link?

  4. feshin
    Member
    Posted 1 year ago #

    Hi Harish--

    Yes, the plugin is shortcode is placed on the main site where the plugin is activated.

    Unfortunately this site is an intranet so I can't give you access to it. Any other way to test it out? I tried enabling the debug.log, but I don't see any errors in it.

  5. Harish Chouhan
    Member
    Plugin Author

    Posted 1 year ago #

    Strange. Its hard to test if there are no bugs too.

    If you have placed the shortcode in your post editor, what does it output? The shortcode text as it is or nothing? If nothing, can you try checking the HTML code of the page.

  6. feshin
    Member
    Posted 1 year ago #

    Yeah - it outputs nothing. The code on the page is just empty - no surrounding divs or anything at all.

    I thought about inserting some javascript alerts in the shortcode function to see if it was even getting called.

    The only thing I can think of is a conflict in the theme. I'll try switching the theme and see what that does.

  7. Harish Chouhan
    Member
    Plugin Author

    Posted 1 year ago #

    @feshin any luck?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • I Recommend This
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic