• Resolved Bliss7

    (@bliss7)


    Hi,

    Your plugin seems to only work with this particular shortcode plugin called Shortcake (Shortcode UI).

    https://wordpress.org/plugins/shortcode-ui/

    Unfortunately, this Shortcake plugin has been abandoned already (Wordfence been giving warning about this plugin).

    What should we users do now?

    Thanks.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Nico

    (@nico23)

    Last time I checked the plugin still works. There were some issues I forgot about though. Not security related!

    So does Wordfence have actual concerns that point to specific code or is it just point-blank warning about every single plugin that was not updated in a long time? That is my guess. So if you want them to scare you away from a working plugin than that is your issue. It’s unfortunate that its abandoned, but I can’t do anything about it. But just because it’s not maintained does not mean it’s automatically a security issue. If I am wrong to point out the actual security issue with the plugin.

    You can also write your shortcodes manually, or you can use Gutenberg and the ARVE Gutenberg Block.

    Thread Starter Bliss7

    (@bliss7)

    @nico23

    I guess you also use or are familiar with Wordfence right? They will always give a warning when a plugin has not been updated in 2 years and mark it as abandoned.

    I am only asking you what are the other options for users or what can you suggest, and I am not using Gutenberg (I am sticking to the Classic WordPress editor).

    I am not sure if I can deactivate the Shortcake plugin because I think all the posts with videos embedded in them would no longer work (for the videos)….

    Thanks.

    Plugin Author Nico

    (@nico23)

    No I do not use WordFence, but I guessed right. The message WP.org shows for old plugins is this:

    This plugin hasn’t been tested with the latest 3 major releases of WordPress. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

    I know it still works in classic editor with classic editor plugin installed. On current WP versions. So despite it being abandoned why not just keep using it if it works? With the focus on Gutenberg, Classic Editor probably will not move very fast, so it will probably continue to work. There are however issues reported on the support forums for it but related to ARVE. But I have not heard any issues from users about it for a very long time.

    I do not know any other options for this, there are probably none.

    But you can just deactivate it, all the posts with arve shortcodes will continue to work. You just lose the previews and shortcode editing on the backend if you disable Shortcode UI. As the name suggests it’s just a UI (User Interface) for creating shortcodes and displaying a preview in Classic Editor. It does not interfere with functionality of the underlying plugins that provide the shortcodes.

    Thread Starter Bliss7

    (@bliss7)

    @nico23

    Thanks for your reply. Would you by any chance know of any other suitable plugin that can replace this Shortcode UI plugin?

    Cheers

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Shortcake UI plugin abandoned’ is closed to new replies.