Support » Plugin: Recent Posts Widget Extended » Short code not working

  • Hi,

    I’ve tried to use the extension inside of a page using the following shortcode without success :
    [rpwe limit=”10″ thumb=”true” ]

    When I try to publish it, the update will fail.
    I’ve tried to remove the options and this is the same.

    The plugin is installed and works as a widget.
    My theme is Head Blog.

    Is there anything I could do to fix this ?

    Thanks a lot

Viewing 3 replies - 1 through 3 (of 3 total)
  • I’m having the same issues with the Gutenberg editor, trying to Save a page with shortcode [rpwe cat=”event” limit=”6″], gives me: Updating failed

    I get the same issue, though with a bit of poking around in FF developer tools Network, I can see the issue causing the update failure.

    The following is being output before the expected json response when the publish button is clicked:

    <style>
    .rpwe-block ul{list-style:none!important; ...
    </style>

    This is generated from
    function rpwe_custom_styles()
    which is called from
    function rpwe_get_recent_posts( $args = array() )

    My fix was to comment out the call to generate the custom styles:

    	// Display the default style of the plugin.
    	if ( $args['styles_default'] === true ) {
    //		rpwe_custom_styles();
    	}

    This also means that the front end formatting will not now have the rpwe formatting applied as the css is not being output.

    What the correct solution is I don’t know, I don’t understand enough about WP.
    But it get’s me out of a hole!

    I’ve done some more searching on this and have found this issue was noted last September https://wordpress.org/support/topic/gutenberg-compatibility-15/ and a github issue raised https://github.com/WordPress/gutenberg/issues/9923

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Short code not working’ is closed to new replies.