Support » Plugin: WP Bitly » Shorlinks Still Showing wp.me

  • Resolved ccolotti

    (@ccolotti)


    I installed the new version today as I have been looking for this. The shortlinks are still showing wp.me links in new posts and all the old posts. Any ideas?

Viewing 15 replies - 1 through 15 (of 15 total)
  • Same issue here. Any idea if you can downgrade the plugin?

    Plugin Author Temerity Studios

    (@temeritystudios)

    Sounds like Jetpack shortlinks. The plugin used to arbitrarily disable that module so that it could override it, but we felt that was a little too unfriendly.

    The filter should be running after Jetpacks, but you can also try disabling the module manually:

    1. Go to Jetpack -> Dashboard.
    2. Scroll to the bottom and click Debug.
    3. Scroll to the bottom again and click Access the full list of Jetpack modules available on your site.
    4. Look for WP.me Shortlinks in the list, and deactivate it.

    I’ll set a task to look into this further and see if WP Bitly can override it without any inter-plugin aggression.

    Plugin Author Temerity Studios

    (@temeritystudios)

    Hey guys, any new information on this? Did the instructions to disable shortlinks in Jetpack happen to work for you? Let me know, if this is a common issue with Jetpack or another plugin I’d like to sticky the topic so others can find it quickly.

    Thank you for following up. Let me check really quickly.

    I clicked the new logo and then the authorize button. It then logged me out of my WordPress session. However, when I logged back in, the shortlinks appeared. Thank you very much for your help with this.

    I did everything you said to do and Bit.ly shortlinks still aren’t being generated.

    Can we somehow downgrade the plugin back two versions to revert this mess?

    Plugin Author Temerity Studios

    (@temeritystudios)

    Nothing has changed with the way shortlinks are generated in the past two versions. The primary update was to the authorization process used with Bitly as they deprecated the old method while the plugin was in limbo.

    Can I get you to double check on your Settings > Writing page that the button that appears next to Connect to Bitly says “Disconnect”? And that the post types (post, page or custom) are properly checked in the list next to Post Types?

    Yes, that is correct. Does it matter if “Let’s debug” is checked off?

    Plugin Author Temerity Studios

    (@temeritystudios)

    No, it won’t affect the operation but it will generate a logfile of responses from the Bitly API if you’d like to leave it on for now. We might need that information to figure this out.

    Alright, the next step is to try and manually get a shortlink and see if they’re being generated properly. You can do this with an existing post or create a new one temporarily for the purpose of testing.

    Open a post (or page, etc), and add the [wpbitly] shortcode anywhere on the page. Save and view, and hopefully you’ll see a bitly shortlink where you added the shortcode. You can also specify a post ID to see if shortlinks are being generated for those posts, such as [wpbitly post_id="42"].

    Let me know what happens!

    No shortlinks. Instead, I got the full permalink. 🙁

    Plugin Author Temerity Studios

    (@temeritystudios)

    Lets do a few things here, I’d really like to get this fixed for you.

    First of all, can you turn on the Debug feature in settings, and then try and generate a few shortlinks again the same way you just did. Afterwards, take a look in your wp-content/plugins/wp-bitly/log/ directory and send me the generated file to info@temeritystudios.com

    Also if you don’t mind, could you email me or post here the URL to the domain you’re using Bitly on, and I’ll see if I can verify it against the API logs.

    Thanks, I appreciate your help. I’ve done the following tasks.

    1) Turned Debug to “on”
    2) Attempted to generate shortlinks using the [wpbitly] shortcode on 4 posts
    3) Sent you the log file
    4) Domain: http://www.droidturf.com/

    Plugin Author Temerity Studios

    (@temeritystudios)

    Marking this thread as solved per version 2.4.3 unless anyone pops back in to state otherwise. Thanks for all the help tracking this down to everyone who participated.

    Plugin Author Temerity Studios

    (@temeritystudios)

    Which of course I forgot to do using the Replay and mark as resolved checkbox, the only way it appears I can do so…

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Shorlinks Still Showing wp.me’ is closed to new replies.