Support » Plugin: WooCommerce ShipStation Integration » Shipstation orders are stuck at Order has been exported to Shipstation

  • Resolved lasti7

    (@lasti7)


    All my recent orders are stuck at Order has been exported to Shipstation

    I don’t have any security plugin’s installed.

    Here is the log report.

    07-18-2019 @ 13:30:04 - Exported 7 orders
    07-18-2019 @ 14:18:08 - Input params: wc-api=wc_shipstation&auth_key=WCSS-xxxx&action=shipnotify&order_number=20014&carrier=USPS&service=USPS+Priority+Mail&tracking_number=xxxxx&capture=true
    07-18-2019 @ 14:18:08 - Missing ShipNotify XML input.
    07-18-2019 @ 14:18:08 - $_REQUEST: Array
    (
        [wc-api] => wc_shipstation
        [auth_key] => WCSS-xxxxxx
        [action] => shipnotify
        [order_number] => xxxx
        [carrier] => USPS
        [service] => USPS Priority Mail
        [tracking_number] => xxxxxxxx
        [capture] => true
        [woocommerce-login-nonce] => 
        [_wpnonce] => 
        [woocommerce-reset-password-nonce] => 
    )
Viewing 4 replies - 1 through 4 (of 4 total)
  • Hari Shanker R

    (@harishanker)

    Automattic Happiness Engineer

    Hi @lasti7!

    You said:

    All my recent orders are stuck at Order has been exported to Shipstation

    Do you mean to say that the orders in WooCommerce are not working at all? Or that they’re not getting exported to ShipStation?

    Do you not see any data there? They do mention: Missing ShipNotify XML input., but I’m not sure as that’s the trigger here, as our extnesion is set to accept orders even without XMO Input. The logs you shared seem to be straightforward and does not show any error as such. However, the $_REQUEST should be followed by an acknowledgement or a reply, which seems to be missing.

    Anyhow, it does say: Exported 7 orders, which probably means that this is working in general.

    Can you try disconnecting and reconnecting ShipStation to your site again? If you still run into the problem, can you share a screenshot depicting the same for us? I recommend https://snag.gy for easily sharing screenshots – please follow the instructions on the page, then paste the URL in your reply to this thread. It works with Chrome, Firefox and Edge.

    Additionally, Could you please send me a copy of your site’s System Status? You can find it via WooCommerce > Status. Select “Get system report” and then “Copy for support”. Once you’ve done that, you can paste it here in your reply to this thread.

    We look forward to hearing back from you!

    Thread Starter lasti7

    (@lasti7)

    Hi @harishanker

    I mean, all the orders are getting exported to shipstation but they are not getting updated with the tracking number.

    Can I disconnect this integration from the admin panel? This setup was done by my dev, he is on vacation right now. I don’t have that login?

    What do you want from the system status? I don’t find anything related to this error?

    Thank you.

    • This reply was modified 1 year, 8 months ago by lasti7.
    Plugin Support D Smith a11n

    (@dsmithweb)

    Automattic Happiness Engineer

    Hi there!

    When you say orders aren’t being updated with the tracking number, do you mean the tracking number within ShipStation isn’t showing up on the orders within WooCommerce.com, as here?

    If that’s the case, I recommend contacting us at https://woocommerce.com/my-account/create-a-ticket — we’ll be happy to help more there, but we’ll need to look at the order details, which aren’t something you’d want to share on a public forum like this one.

    Please let us know if we can assist with anything else!

    Plugin Support D Smith a11n

    (@dsmithweb)

    Automattic Happiness Engineer

    Hi again!

    We haven’t heard back from you in a while, so I’m going to mark this as resolved. If you have any further questions, feel free to start a new thread!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Shipstation orders are stuck at Order has been exported to Shipstation’ is closed to new replies.