Support » Plugin: WooCommerce Shipping & Tax » Shipping tax being charged to Zero Rate accounts

  • Resolved stylise

    (@stylise)


    Our zero rate accounts are being charged tax on shipping, while not being charged tax on anything else.

    Is there a way to make sure that these accounts will not be charged tax on their purchases whatsoever, even though they exist in a taxable state?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Support Aashik P – a11n

    (@aashik)

    Hi there!

    Am I understanding correctly that you’re seeing TAX applied on a product with TAx class set to Zero Rates?

    I’m asking because this is not something I can replicate on my own test store:

    Test-cart
    Link to image: https://d.pr/i/4u9f4H

    When I add a product with TAX class set to Standard:

    cart
    Link to image: https://d.pr/i/1mDHd2

    TAX settings for the product where rates were returned:

    cap
    Link to image: https://d.pr/i/5fcb1A

    For the product with Zero Rate configured:

    zero
    Link to image: https://d.pr/i/b7R42W

    Can you please share a screenshot of your Zero rate TAX settings under WP Admin > WooCommerce > Settings > Tax > Zero Rates, and a screenshot of the product edit page itself?

    If you don’t already have a screenshot service installed, you can try https://snipboard.io or http://skitch.com/.
    You can share the direct link to the image as a response to this topic.

    [Please redact any private details, including address, name, email address, transaction details, API Keys, Passwords, etc]

    Plugin Support Aashik P – a11n

    (@aashik)

    Howdy!

    We haven’t heard back from you in a while, so I’m going to go ahead and mark this thread as resolved. If you have any other questions please start a new thread.

    Cheers!

    Thread Starter stylise

    (@stylise)

    Hey sorry, I didn’t receive and email notification when notifying me of your initial response.

    I am seeing that a specific user role is being charged tax on SHIPPING, even though that role is set to ZERO RATE. Tax isn’t being charged for products with a standard tax class.

    Plugin Support Aashik P – a11n

    (@aashik)

    I am seeing that a specific user role is being charged tax on SHIPPING, even though that role is set to ZERO RATE. Tax isn’t being charged for products with a standard tax class.

    By default, TAX settings aren’t based on user roles. For further investigation, can you please share a screenshot of your Zero rate settings?

    If you don’t already have a screenshot service installed, you can try https://snipboard.io or http://skitch.com/.
    You can share the direct link to the image as a response to this topic.

    [Please redact any private details, including address, name, email address, transaction details, API Keys, Passwords, etc]

    Along with that, could you please also share a copy of your site’s System Status? You can find it via WooCommerce > Status.
    Select “Get system report” and then “Copy for support”.  Once you’ve done that, paste it here in your response.

    Thread Starter stylise

    (@stylise)

    Here’s my tax settings–
    https://snipboard.io/XKGfSy.jpg

    I am also using an additional plugin to allow for role-based pricing, and within that the role in question is set to use my “zero rate” settings. This is working as expected apart from tax applying to the cost of shipping.

    I’d like to confirm that it is not an issue with my settings or the “WooCommerce Shipping & Tax” plugin itself.

    Thank you kindly for your assistance.

    Plugin Support Aashik P – a11n

    (@aashik)

    Hi there!

    I see you’ve disabled Automated taxes.

    I am also using an additional plugin to allow for role-based pricing, and within that the role in question is set to use my “zero rate” settings. This is working as expected apart from tax applying to the cost of shipping

    If the problem is specific to the configuration on your additional-plugin, the best way forward would be to reach out to the plugin developers directly as this forum is for assistance with WooCommerce shipping and Tax extension features only.

    Thread Starter stylise

    (@stylise)

    So as far as you can tell, my settings are as they should be and this issue doesn’t have to do with this plugin?

    Plugin Support Aashik P – a11n

    (@aashik)

    Only the plugin developer for role-based tax settings you’ve configured can answer your question on if the settings are right, but I can say that WooCommerce Shipping and tax extension is not in play here as you’ve not enabled automated taxes:

    Automated-tax
    Link to image: https://d.pr/i/IDiI9U

    Thread Starter stylise

    (@stylise)

    I have tax automation disabled because I’ve set them up manually to only charge tax for sales in the state that we operate from.

    Taxes are working fine. The only thing that isn’t working is zero rate roles being charged tax on shipping when I have that setting disabled. That setting comes directly from the WooCommerce Shipping & Tax plugin.

    https://snipboard.io/Z0T3Ac.jpg

    Plugin Support Aashik P – a11n

    (@aashik)

    That setting comes directly from the WooCommerce Shipping & Tax plugin. https://snipboard.io/Z0T3Ac.jpg

    That setting comes from core WooCommerce plugin.

    You can read more about the features that come with WooCommerce Shipping and Tax at https://docs.woocommerce.com/document/woocommerce-shipping-and-tax/

    Core WooCommerce options for TAX are described here: https://docs.woocommerce.com/document/setting-up-taxes-in-woocommerce/

    Thread Starter stylise

    (@stylise)

    My mistake. Thanks for looking into it, I appreciate your help!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Shipping tax being charged to Zero Rate accounts’ is closed to new replies.