Support » Plugin: WooCommerce Weight Based Shipping » shipping not working correctly

  • Resolved jordibrain

    (@jordibrain)


    We have installed the plugin and now we selected pickup locations (2) and a sending methode. But the problem we have now is that he automatic select 1 of the 2 pickup locations. but he must automatic be on sending. so this option must be on top and selected, the 2 pickup locations are extra and people can choose those if they need to. How can you or we change this?

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Dan

    (@dangoodman)

    By default, the first shipping option is selected.

    To make the WBS shipping option coming first you have to put both local pickup and WBS shipping methods together in a shipping zone and drag the WBS one above the local pickup.

    Does that make sense?

    Thread Starter jordibrain

    (@jordibrain)

    we already did this, but it seems this still not working right. you can see it in the screenshot how we set it up.

    screenshot

    Plugin Author Dan

    (@dangoodman)

    Thank you for the screenshot.

    Do you have also some global WBS rules at WooCommerce -> Settings -> Shipping -> Weight Based Shipping (as opposed to WooCommerce -> Settings -> Shipping -> Shipping Zones)?

    Thread Starter jordibrain

    (@jordibrain)

    Don’t know what you mean?
    Can i send you login details so you can look yourself?

    Plugin Author Dan

    (@dangoodman)

    Please check this screenshot: https://imgur.com/KiXuw2M

    Thread Starter jordibrain

    (@jordibrain)

    Their we have this see the screenshots below

    link 1
    link 2

    Plugin Author Dan

    (@dangoodman)

    Thanks.

    So you do have global WBS rules. WooCommerce shows such shipping options at the last place, below the ones coming from shipping zones.

    To control the order, you would have to move your global WBS rules into a shipping method under a shipping zone.

    Thread Starter jordibrain

    (@jordibrain)

    Thanks this worked out!

    Plugin Author Dan

    (@dangoodman)

    Great! Thank you for the update.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.