Support » Plugin: WooCommerce » Shipping methods are not selected

  • When doing the checkout, my SHipping methods are not selected, they are listed one by one giving no chance for a customer to select preferred shipping method. Though, in Woocommerce Settings I have “radio buttons” enabled for shipping. With the payment methods everithing is okay, thay are displayed correctly.

    Please, help to solve this issue and to have 2 types of shipping methods with radio buttons to choose for my clients.

    Thank you!

Viewing 15 replies - 1 through 15 (of 22 total)
  • I am also having this issue after the update. I can click the radio buttons for shipping options, but they deselect themselves and then if you try to click “Place Order”, the page refreshes with an “Invalid shipping method” error.

    Please help if you have had this issue and fixed it somehow!


    @pansyflower – If you’re ok with having a drop-down box of options for shipping instead of radio buttons, I have now found that switching my shop options to use a drop-down box fixed the problem without having to make any other changes.

    I am having this issue as well after updating to 2.0.3 on my staging site. However, changing the selection to a drop-down list did not fix the issue, it is still de-selecting after the price is updated.

    It seems that the price is being updated properly, however when I try to complete an order i am receiving a validation error of ‘Invalid Shipping Method’.

    Any insight would be much appreciated, Thanks,

    Yes, I have the same as stonebreaker, after switching to drop down it does not help. By now I have solved this issue by deactivating my shipping at all)))))) it really helped!!)))

    I finally found a resolution to this issue. The 2.0 update moved the logic that displays the shipping methods on the cart and review order pages to it’s own file, with some changes. If you are using a modified template for these pages as I am, by removing the code that displays the shipping options and pulling the new file with the following code it should work properly. At least it did for me, good luck.

    <?php woocommerce_get_template( 'cart/shipping-methods.php', array( 'available_methods' => $available_methods ) ); ?>

    I have the very same problem with the radio buttons. Stonebreaker, can you be more specific about which template and where the code should be inserted?

    I have tried the select box rather than radio buttons. The select box calculates properly and allows shipping, but it is unstable, and defaults always back to local delivery when a different shipping method is selected, even if the shipping amount is registered correctly with the different shipping method.

    The site is

    Roy Ho


    @allanbu this only applies if you have either moved or modified the template files to your theme folder. If you haven’t, then this is not your issue. But if you have, you need to make sure you copy over the latest template from the plugin to your theme folder and if you have modified it, then you need to port your changes over to the new template file as well. The templates are located inside your theme folder under woocommerce folder.

    If you’re using a theme, then you should ask your theme developer to take care of this for you.

    Hi Guys,
    i too just fixed the problem on a custom theme by editing the file themename->woocommerce->cart->review-order.php

    On or near line 83 the options or radio buttons for the dropdown list of shipping methods had this code which check the session if a option has been selected
    selected( $method->id, $_SESSION['_chosen_shipping_method'], false )
    i then replaced it with this
    selected( $method->id, $woocommerce->session->chosen_shipping_method, false )
    This fixed the problem.
    Hope this helps.

    My WooCommerce shipping has been driving me batty!

    I cannot get more than 1 method at a time to work and now its quite broken with the same error message as others have:
    >>Sorry, it seems that there are no available shipping methods for your location (Canada). If you require assistance or wish to make alternate arrangements please contact us.<<

    to get the flat-rate drop downs to work I had to lower all rates by 1$ and then add a 1$ shipping option. IT works, BUT it doesnt allow other methods to show.

    HAve tried enabling and disabling all the methods and creating and un creating them as defaults and still its broken.

    The coupon code box shows only on the cart page and does nothing.

    I tried to do the fix above and that file [review-order.php] doesnt exist in my WooComm directory.

    Would love some feedback or help!!

    @design2code That fixed the problem. But my review-order.php file was the inside mythemename/woocommerce/checkout folder.

    Thank you! 😀

    Plus, in the mythemename/woocommerce/cart/totals.php folder, you can do the same: replace $_SESSION['_chosen_shipping_method'] with $woocommerce->session->chosen_shipping_method so the totals will me updated in the cart too.

    Thank you Design2code, your advice solve the problem also for me!


    I have a similar issue, in desperate need of advice. I tried design2code’s fix but that code is already correct.

    I’m using the latest woocommerce version with latest rustik theme version and paypal. It’s my first store and the launch is held up behind this one issue.

    I’m not sure where the shipping option dropdown/radio buttons are supposed to appear but they display nowhere on the site. Ive tried dropdown and radio button options, no joy.

    On the product page, no shipping options appear. On the cart page the default shipping displays with no option to change it (just text, no dropdowns etc). On the checkout page the shipping does change correctly according to the country selected from the dropdown on the address form.

    I’m using the site with paypal so what i need is a very simple option to select either local or international shipping so as not to waste buyers time entering unneeded addresses etc. It could be either on the product, cart or checkout. I guess cart is best.

    Please advise!

    @ukbloke28 have you enabled any shipping methods in the admin area?
    The radio/select options appear on the cart page where it currently reads “Free Shipping”.
    Once you have shipping options enabled they should appear as options..

    Let me know how it goes for you and i hope you come right with your deadline.

    Hope this helps.

    Design2code, Thank you! It helped me today! Perfectly)

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Shipping methods are not selected’ is closed to new replies.