WordPress.org

Support

Support » Plugins and Hacks » Shipping cost – wooCommerce 2.0.3

Shipping cost – wooCommerce 2.0.3

  • I think maybe there is a bug in the shipping cost. Flat rate. I cannot longer have a standard shipping cost. Then woocommerce ask the costumer to fill in details. I need to have a sub-cost, exemple shipping class A or B, or I need a standardcost or something added. Why this? Will that be fixed? Everything work great until update.

    http://wordpress.org/extend/plugins/woocommerce/

Viewing 15 replies - 1 through 15 (of 20 total)
  • I too lost ALL my shipping options, not just First Class, but also Flat Rate and Free Shipping as well. Nobody can buy anything because the shipping feature is completely broken. Using Woo with Child’s Agency Theme. I’ve opened a ticket but have no solutions yet…i’m losing money everyday…this is awful. Thinking of switching to a completely different ecommerce. EVen on the pages i’ve fixed, the purple warnings are still at the top of every page. Too large of an update for far too many themes at once. I just want my shipping options back…anybody have any ideas?

    https://vapelation.com/checkout/

    I have the same problem with the update to 2.0.3, shipping rates I set in the old version appears on the interface but aren’t showed on the website. There’s an additional problem: I put the right settings to allow people to use paypal but Woocommerce doesn’t recognize them. Please help, the website worked perfectly before the update.

    p.s. I’m using Mystyle theme

    Same issue here – All shipping options are unavailable after the update:

    http://www.salsa-trips.com/shop/fsf-fp-option

    Backend looks like before. 3 shipping options are saved. Theme: Canvas

    My shipping costs are gone on safari and firefox. It works on chrome only.

    My temporary fix was to “Enable the shipping calculator on the cart page” .

    It seems like we have solved the problem: in the flat rate option you need to place a minimum cost per order. We put our first option as the default one in the field “method name” (I’m translating from italian so I don’t know if it’s written exactly in that way) and the price in the field “cost per order”. At last I deleted the first option in the field “shipping options” and now it works as before the update. Hope it will help.

    Sorry, but this doesn’t help.

    a) deactivating the cost per order, deactivates the shipping method completely. Hence it is not possible to calculate a percentage or minimum amount etc. like it has been before the update.

    b) putting any amount as cost per order, will pick exactly this amount instead to calculate the percentage or minimum amount etc.

    Fixed it. I have three shipping options that I use with my USPS extension. USPS/Flat Rate/Free Shipping. Under flat rate at the bottom of the page, there is a set-up where you can override all other settings by adding FirstClass/4.00/yes, Priority Shipping/5.35/yes, etc. This does not work anymore. You have to go into each page separately and set them up individually. Go to USPS and set up First class and set the amount and minimum amount. then go to Flat rate, Priority shipping, set the amount and minimum amount, then go the Free shipping and put a minimum. I put $75 because i offer free shipping with orders over $75. Then the options show up in the cart. Now I have to figure out how to fix USAepay, my gateway is broken now too.

    Sorry, I can’t see this on your page. The shipping is always 5.35 USD. There is neither any choice available nor is it calculated. It just picks the value from the settings, like I described.

    I think that’s a bug and hope that somebody will soon help to fix it. THX

    I only offer three options…they are not calculated even though i had to turn on calculating shipping costs. There are two flat rate choices, and free shipping if over $75 purchase or coupon code. That’s all i need, but as far as calculating from your products, i guess it’s not fixed.

    Is there some hope that woocoomerse will fix tis?

    I’m afraid, at least not short-time.

    So in case anybody has an idea, how to solve this, please post it here. The premium support of WooThemes also doesn’t answer and there is no useful information in their documentation or forum.

    Not sure if this helps,

    I had a problem with a new install where I couldn’t get the delivery options to show and just displayed “Sorry, it seems that there are no available shipping methods for your state. Please contact us if you require assistance or wish to make alternate arrangements.”

    For some reason when I created a new shipping class under products and added it to the costs within the flat rate options, then deleted the shipping class under products it works.

    The only problem I have now is I can’t remove the cost option under the flat rate shipping options.

    Ah well, just happy that people can order now.

    [Fixed!]

    They’ve changed the behaviour. It is now necessary to add in a sum for Cost Per Order. You can make it what you like (I added in 0.50) and then deduct that amount from the Flat Rate Shipping Options you’ve set up in the Additional Rates box and it should all work.

    So for example:

    You want
    Europe Shipping to be 5.50 and
    Courier to be 10.00

    You set up:

    Cost Per Order: 0.50

    and add the following to the Additional Rates box:

    Flat Rate Shipping Options:

    Europe | 5.00 | order
    Courier | 9.50 | order

    Once you’ve done this, the shipping rates magically appear in the Cart and Checkout as they used to.

    They clearly need to document this asap.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Shipping cost – wooCommerce 2.0.3’ is closed to new replies.