WordPress.org

Support

Support » Plugins and Hacks » WP eCommerce » Shipping address "State" field not working

Shipping address "State" field not working

  • The “state” field on my website’s Billing/Shipping Address form isn’t working correctly.
    The Billing Address’ “state” field has no label and isn’t marked as “required” even though it’s set in the options, also the Shipping Address’ “country” and “state” fields can’t be edited.

    When I try to submit the form the page reloads with an error message “Please enter a valid State.” Or, If I check the “Shipping same as billing” option, I’m redirected to a PayPal error page complaining that the address is invalid.

    The only payment method I have available is PayPal Payments Standard.
    I am currently using the most recent versions of both WordPress and WP e-Commerce.
    Any help with this would be greatly appreciated.

    http://wordpress.org/extend/plugins/wp-e-commerce/

Viewing 2 replies - 1 through 2 (of 2 total)
  • WP e-Commerce tanked their support forum, so here is the only place to get info. I’ve spent hours searching for the answer (as apparently hundreds others have as well).

    The issue has been ongoing for years. No viable work around is listed. For the love of God, can someone who’s resolved the issue weigh in?

    The one hack I did find talked about inserting a new record into the wpsc_region_tax table, which is no longer a part of the system (as of today’s date).

    Any other suggestions? My orders are being exported and sent to the fulfillment center with no state!

    The only thing I’ve been able to do is disable the “state” field and enable the “country” field (which happens to also include the state in the checkout form). However, the country and state are backwards (country dropdown THEN state dropdown) and I haven’t yet been able to switch the order.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Shipping address "State" field not working’ is closed to new replies.
Skip to toolbar