WordPress.org

Forums

[resolved] Shibboleth plugin does not hold "Managed" settings (6 posts)

  1. Zooney
    Member
    Posted 5 years ago #

    The shibboleth plug-in does not seem to be able to hold the individual "Managed" settings under "User Profile Data" on the Shibboleth administration section.

    Steps to reproduce:
    -check any of the Managed checkboxes
    -hit "Save Changes"

    Versions:
    Wordpress Mu 2.9.1
    Shibboleth plug-in 1.3

    http://wordpress.org/extend/plugins/shibboleth/

  2. Zooney
    Member
    Posted 5 years ago #

    ...more accurately, the settings are being saved into the database, but WordPress's "checked()" function doesn't seem to be working properly or something...

  3. Zooney
    Member
    Posted 5 years ago #

    Ah, the problem is that __checked_selected_helper is explicitly typecasting the $helper and $current variables...

    In 2.8.6 these values weren't typecast...

  4. Zooney
    Member
    Posted 5 years ago #

    ...if anyone has been following my general schizophrenic self-dialogues, if you want to fix this problem, you'll have to go into options-admin.php and change things like :

    checked( $shib_headers['first_name']['managed'])

    to

    checked( $shib_headers['first_name']['managed'], 'on' )

    ...and things should be fine.

  5. Jay Collier
    Member
    Posted 5 years ago #

    Thank you for taking the time to post your solution!

  6. jmdh
    Member
    Posted 4 years ago #

    Just to note that this has been fixed in version 1.4 of the shibboleth pluging which was released a couple of weeks ago.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags