WordPress.org

Forums

Shibboleth
Shibboleth options on multisite WordPress installation (14 posts)

  1. Dan.LaSota
    Member
    Posted 1 year ago #

    I am testing an install of this Shibboleth plugin on a multisite WordPress install.
    like so: *.site.subdomain.org

    It seems like the options for the Shibboleth plugin are restricted to each site separately versus global settings for the entire multisite. I only see the options for Shibboleth under Tools >> Shibboleth for particular blogs. But the settings seem global.

    Wouldn't it be better to have them under the Network Admin > Settings (perhaps)?

    https://wordpress.org/plugins/shibboleth/

  2. jsdavis02
    Member
    Posted 1 year ago #

    Dan I am curious about this as well. As far as I am concerned the configuration should be at the network level, and even with the mu plugin installation folder installation method and instructions it seems to be per site.

  3. Dan.LaSota
    Member
    Posted 1 year ago #

    Maybe it was easier for the authors to leave it where it was and filter for super admins in multi-site WP installs. I'm just guessing.

    Some of the language on the support pages for the Shibboleth plugin are out of date. It would be nice for the authors to update them. It would bring more confidence to the plugin itself.

    I hope to have this task conquered by the end of next week!

  4. bhylton
    Member
    Posted 11 months ago #

    Dan, did you have any luck with configuring Shibboleth for multisite? You might check out this patch, if not:

    http://www.ibiblio.org/archive/2011/10/wordpress-multisite-plus-shibboleth/

    We've long had a goal to get Shib working with two large domain-based multisite networks. Using the patch above worked, but ultimately we still had conflicts with the Shibboleth and Domain Mapping plugins (for *domain.edu sites) and that sent us back to AD/LDAP.

    Would love to know if you're successfully using Shib for your netowork.

  5. Dan.LaSota
    Member
    Posted 10 months ago #

    I had to put this project down for about 6 weeks. But I'm back on it.

    REVISED details:
    Administrators of subdomain sites *do* have access to the Shibboleth Settings under /wp-admin > Tools > Shibboleth
    The Shibboleth settings are global!

    This is *not* good. We would not be able to run this in a production environment.

    It seems like the Shibboleth settings should be moved to the main site (site id = 1)
    so that only administrators of the main WordPress domain site would be able to change the Shibboleth preferences.

    But this issue of allowing sub-domain administrators to access and alter the global Shibboleth settings hasn't gone away.

    I will try out the patch that bhylton provided, but it would be nice to hear from the authors as to their reaction and any plans to remedy this.

  6. Dan.LaSota
    Member
    Posted 10 months ago #

    Just a little research on the WordPress Codex under roles:
    http://codex.wordpress.org/Roles_and_Capabilities

    Access to the Shibboleth Plugin Settings should be restricted to "Super Admins" (this is my request)

  7. jdelsemme
    Member
    Posted 10 months ago #

    We are facing the same problem here at UCSC. We would like to use shibboleth with multisites, but want to restrict changing the shibboleth settings to the network admin. I found this possible solution:
    http://wordpress.org/support/topic/shibboleth-plugin-needs-maintenance-help
    which seems to work, but I'm not a WordPress plugin developer, and would like confirmation that this is something reasonable to do until the developers fix this problem.

    Here is a diff of the file wp-content/plugins/shibboleth/options-admin.php to modify:

    5,12c5
    < // begin changes
    < 	//add_action('admin_menu', 'shibboleth_admin_panels');
    < 	add_action( 'network_admin_menu', 'shibboleth_network' );
    < function shibboleth_network() {
    <         $hookname = add_submenu_page('settings.php', __('Shibboleth Options', 'shibboleth'),
    <                 __('Shibboleth', 'shibboleth'), 8, 'shibboleth-options', 'shibboleth_options_page' );
    < }
    < // end of changes
    ---
    > 	add_action('admin_menu', 'shibboleth_admin_panels');
  8. jkhongusc
    Member
    Posted 10 months ago #

    This sounds like a bug. Having menu settings in the site admin affect network settings. I do not use this plugin so I cannot make any suggestions. It could be as simple as moving the settings to network admin, but that depends if each site needs its own settings.

    FYI at USC we have a large WP installation of over 200 site and we use Shibboleth for (/wp-admin) authentication. We needed special customizations so I wrote our own plugin. It is very easy to do. Unfortunately our plugin is customized specifically for our enviroment, so it most likely wouldnt work for anyone else.

  9. luckster99
    Member
    Posted 10 months ago #

    For those of you who have worked with the shibboleth plugin or created your own, was it a problem that account creation via shibboleth authentication automatically adds the user to the main site? My dilemma is that I don't want our users to be automatically placed in the main site....I would like them to have no site until they create one. I think being in the main site will be confusing for them because they will have to know to switch over to their site each time they log in.

    jkhongusc - does your version associate new users with the main site?

  10. luckster99
    Member
    Posted 10 months ago #

    Also, I meant to ask you jkhongusc what problems you had with domain mapping because we'll be using a domain mapping plugin also

  11. jkhongusc
    Member
    Posted 10 months ago #

    I do not want to go off-topic. If you have questions for me, send me an email: jkhong at usc dot edu

  12. mitcho (Michael Yoshitaka Erlewine)
    Member
    Plugin Author

    Posted 9 months ago #

    Hi all,

    I made an update to the development version on the github repository, which may resolve this issue. Thank you to those of you who brought this to my attention.

    https://github.com/mitcho/shibboleth/issues/8

    I don't have an active Shibboleth multisite setup right now, so I would appreciate it if those of you with live installs can try this version and see if it resolves the issue.

  13. Dan.LaSota
    Member
    Posted 9 months ago #

    I will try it out!
    Thanks.

  14. jdelsemme
    Member
    Posted 9 months ago #

    I've tried it on one multisite, and the shib menu now appears in the correct place. Thank you!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Shibboleth
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.