Jetpack by WordPress.com
[resolved] Sharing: print and email buttons not working (7 posts)

  1. Chris_Maes
    Posted 3 years ago #

    I use sharing on my website http://rookzondervuur.be and both twitter and facebook work but print and email does not.

    When you click the button it redirects to the same page but adds ?shared=email&msg=fail to the URL for email and #print for the print button.

    I tried several browsers and logged in or logged out but the behaviour is the same.


  2. Chris_Maes
    Posted 3 years ago #

    Update: after reading some other posts I started disabling my other plugins and found out that jetpack sharing is not compatible with the plugin "Category Grid View Gallery"

  3. Jeroen
    Posted 3 years ago #

    I am also having trouble with the email button. The email box is added at the end of my page so I have to scroll all the way down.

    I've tried disabling all plugins, but I couldn't find one that is conflicting with the share button. So perhaps it is due to my theme, which is from Photocrati.

    Here you can see what is happening: http://test.jeroenakershoek.nl/blog/landscape/woonkamer-in-brussel/

  4. Jeremy Herve
    Jetpack Mechanic
    Plugin Author

    Posted 3 years ago #

    Could you have a look at your theme's footer.php file, and make sure that the call to wp_footer is the very last function before the closing </body> tag?

  5. Jeroen
    Posted 3 years ago #

    Great help again!
    It wasn't at the end, but when I moved it my problem was fixed.

    I checked the documentation for wp_footer and there it also says that it should be the last call. I will forward this to Photocrati, so they can correct this for future updates.

  6. ambj1994
    Posted 3 years ago #

    I just installed jetpack to http://www.thekitchentableadvisor.com.
    I use sharing buttons such as email and print. But they are not working. Nothing happens when I click them. I know nothing about coding. Please help.

    Also I did a test by adding my email address to Get updates on one of our current blog post. I click the submit button and got a msg, "The feed does not have subscriptions by email enabled." I don't have feedburner and don't want to use it. That is why I opted for installing jetpack. How can I remove this error msg and make sure it's working? Thank you.

  7. Jeremy Herve
    Jetpack Mechanic
    Plugin Author

    Posted 3 years ago #

    @ambj1994 I had a look at your site, and your theme seems to be loading an old version of jQuery (1.4.2) instead of using the version that comes bundled with WordPress (1.8.3 at the moment).

    It can create multiple conflicts with WordPress and with other plugins like Jetpack. You can read more about it here:

    You'll want to look for the function loading jQuery in your theme's header.php file, or in the functions.php file. Once you find that function, you can remove it and enqueue the proper version of jQuery as explained here:

    If you do not feel comfortable editing PHP files, you can also contact the theme author and ask them to solve the issue.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Jetpack by WordPress.com
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.