Support » Plugin: Jetpack by WordPress.com » Sharing on Google Plus Private..? Why?

  • Resolved LuigiMdg

    (@luigimdg)


    Hi,
    i have correctly installed google plus and connected it on Facebook Profile and on Google Plus… On Facebook is all ok but on Google Plus the Jetpack share the posts but in private mode… When i go on Google Plus i view “This Is Shared Only for You”… Where is the problem?

    https://wordpress.org/plugins/jetpack/

Viewing 15 replies - 1 through 15 (of 16 total)
  • Up

    The problem is buried in your Google+ settings:

    1. Log into G+ and go to Settings.
    2. Scroll down to Manage other apps & activity.
    3. Click Manage apps & +1’s on posts.
    4. Switch to the Apps tab.
    5. Next to WordPress, under Visible to, change the setting to Public.

    i’m going on this page but wordpress/jetpack isn’t on this list…

    I suggest you look again. For Jetpack to be able to post to G+, there has to be an entry for WordPress on the Apps tab.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    @robert Thanks for jumping in! You’re correct.

    @luigimdg, If you don’t see WordPress on the list of connected apps, make sure you’re connected with the Profile or Page that you’ve connected to your site. To switch between personal account and pages on Google+, you can use the icons in the top right corner.

    Hi, thank you for reply… I have connected the jetpack by the sharing page and he publish the article when i publish this, but in private mode… Is connected and publish but don’t appear on the list… Please help me

    Thank you Robert Trevellyan!!!
    I have find it 🙂

    Glad I could help :o)

    These instructions don’t seem to work anymore. Here’s what I see when I go to the WordPress app settings on Google+.

    Nothing there about visibility.

    How can I solve this problem?

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    That’s indeed a known issue; the option used to be available during the connection process, as well as in your Google+ settings, but Google+ removed that option a few weeks ago. We contacted them about it, and are waiting for a reply. I’ll post again here as soon as I have some news!

    Now I know, which is helpful. Thanks!

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Hi there,

    I have good news!

    A few weeks ago, Google+ made some changes to their API. In doing so introduced some issues with Publicize. The module still worked, but the updates posted by the WordPress app on your Google+ Profile or Google+ Page were only visible to you.

    In the past few weeks, we’ve worked with Google+ to start using a new API. That API works just like the old one, with one exception: publicized posts are now public. You can’t change the visibility of publicized posts to “My Circles”, or anything else.

    If you’re happy to have Publicize publishing public posts to your Google+ Profile or Page, you can follow the instructions below to delete your old connection, and then reconnect your Jetpack site to your Google+ account:
    https://jetpack.com/support/publicize/google/#reconnecting

    I hope this helps.

    Thanks Jeremy for this post.
    So you mean that it’s enough disconnect and reconnect G+ to wordpress in order to have publish posts?
    So now all automatic g+ posts coming from jetpack that before were private, now will be public?
    This is a good new, but I suppose it is not possible change it isn’t it?
    Thanks again.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    it’s enough disconnect and reconnect G+ to wordpress in order to have publish posts?

    That’s correct.

    So now all automatic g+ posts coming from jetpack that before were private, now will be public?

    All your existing posts won’t be affected. However, all posts published by Publicize once you reconnect will be public.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Sharing on Google Plus Private..? Why?’ is closed to new replies.