WordPress.org

Forums

Jetpack by WordPress.com
[resolved] Sharing on Facebook -> takes the wrong image (5 posts)

  1. Vanhael
    Member
    Posted 1 year ago #

    Hi,

    since a couple of days (maybe since the last Jetpack-update?), I have a problem, when I share a post on Facebook.

    I looked on this forum and I'm not sure this can be resolved, maybe it's up to Facebook, but at least, I can try :)...

    Example of a post: http://www.moviesnackx.com/last-vegas-2013/

    When sharing to Facebook, it takes an image of the slider (or of the cache), instead of the featured image of the post. Before the last update, everything worked well.

    When looking at the debugger, I get this message:
    "Provided og:image is not big enough. Please use an image that's at least 200x200"... But my featured image is 270x400, so I don't see the problem.

    Is there any solution?

    Thanks in advance!

    http://wordpress.org/plugins/jetpack/

  2. plake777
    Member
    Posted 1 year ago #

    LinkedIn is taking the wrong image too.

    When you look at the source for each blog post its using the image from the home page (for every page).

    <meta property="og:image" content="http://heartstonejourney.com/wp-content/uploads/2013/06/hsj_logo.png" />

    This is the og tag for every post. Something definitely changed since the last update.

  3. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    When you share a post on Facebook, or when Jetpack Publicize publishes a post to your Facebook page, Facebook crawls the page and looks for Open Graph meta tags in the head to build a complete post preview (with an image, title, description, ...).

    Jetpack automatically adds these meta tags to your site, unless you already use another plugin to handle Open Graph tags for you. Looking at your site, you seem to be using a plugin named "Open Graph Meta Tags for Facebook and LinkedIn Sharing". Jetpack consequently doesn't have any control over the images used by Facebook in its post previews.

    As @plake777 mentioned, LinkedIn uses the same Open Graph tags to build its post previews, so the problem is likely to hit both platforms if your Open Graph tags are not correct.

    To verify if the tags are properly set up, you can view the source code on your site, or use Facebook Debugger to see what Facebook sees:
    https://developers.facebook.com/tools/debug

    It's worth noting that other site owners have also reported issues with Facebook in the past few weeks. Sometimes, even if the Open Graph meta tags are properly set up Facebook ignores them, or bugs with the image size as you've realized. Others have already warned Facebook about the issue here:
    https://developers.facebook.com/bugs/483025408453290

    @plake777 You're also using a different plugin to manage Open Graph Meta tags. That image tag you mentioned is indeed the same on all your pages, but it is not added by Jetpack. I can't say for sure, but I think it is added by the All in One SEO plugin; I know AIOSEO was recently updated and added an Open Graph option, and you seem to be using the plugin on your site, so it could be it.

  4. plake777
    Member
    Posted 1 year ago #

    Thanks Jeremy, at least that rules out Jetpack and points me in the right direction.

  5. Vanhael
    Member
    Posted 1 year ago #

    Ok, thx for the answer Jeremy!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Jetpack by WordPress.com
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.