WordPress.org

Support

Support » Plugins and Hacks » Sharing Buttons not showed but Jetpack installed and configured

Sharing Buttons not showed but Jetpack installed and configured

Viewing 6 replies - 1 through 6 (of 6 total)
  • Update:
    i’ve tried to show the sharing button using print sharing_display();between <ul> tag in $share but doesn’t work as i want. Sharing button was displayed above my post but not in the picture overlay.
    This is the code someone have an idea? how can i force to show the sharing button in the overlay div?

    $share = '';
              # Sharing_Service is a JetPack class and it must be installed for sharing to work.
              if (class_exists('Sharing_Service') && $this->options['show_sharing']) {
                $layer_has_info = true;
                $sharer = new Sharing_Service();
          		  $enabled = $sharer->get_blog_services();
                $this->share_img_url = $val['permalink'];
                $i = 0;
    
                $div = '<div class="galleria-layeritem sharedaddy sd-sharing-enabled '.
                       'robots-nocontent sd-block sd-social sd-social-icon sd-sharing '.
                       'sd-content">';
    
                $share = $div.'<ul>';
        			  foreach ($enabled['visible'] as $id => $service) {
        				  $share .=  '<li class="share-' . $service->get_class() . '">' . $service->get_display( $post ) . '</li>';
                  ++$i;
                  if ($i % 2 == 0) {
                    $share .= '</ul></div>'.$div.'<ul>';
                  }
                }
                $share .= '</ul></div>';
                $this->share_img_url = '';
                //$this->ob_log($share);
              }
            }
            $this->json .= "{id: ".$val['post_id'].
                           ", image: '".$key.
                           "', thumb: '".$thumb.
                           "', permalink: '".$bookmark."'";
            if ($layer_has_info) {
              $this->json .= ', layer: \'<div class="galleria-infolayer">'.
                         '<div class="galleria-layeritem" style="padding-right: 20px;">'.
                         $title.$caption.$description.$info.'</div>'.
                         $link.$map.$bookmark.
                         '<div class="galleria-layeritem" style="padding-right: 20px;"></div>'.$share."'";
            }
            if ($extra) {
              foreach (array("thumbnail", "medium", "large", "full") as $size) {
                $img = wp_get_attachment_image_src($val['post_id'], $size);
                $this->json .= ", ".$size.": ['".$img[0]."', ".$img[1].", ".$img[2]."]";
              }
            }
            $this->json .= "},\n";
            $images[$key]['id'] = $val['post_id'];
          }
        }
        $this->json = rtrim($this->json, ",\n");
        $this->json .= "\n],\n";
      }

    Ops
    i’ve post a duplicate thread. I edit this with my apologize…
    😀

    thanks to everyone want help me

    Hi!
    i’m still here trying to solve my sharing buttons problem…
    I didn’t found a way to force to show the sharing button in the right place, next to permalink. Jetpack is installed and sharing service well configured as fullscreen galleria but nothing.
    I’ve tryed to switch template to twenty twelve but the problem still remain.
    i’ve seen that on http://torturedmind.org/ the service works well, could you write me which kind of version of Jetpack you use and if you have encountered some problem like mine?

    thanks

    p.

    Plugin Author pdamsten

    @pdamsten

    I have latest Jetpack (2.3.5) and I haven’t encountered same problem that you have.

    Hi,

    as odd as it sounds, but the buttons show up after changing galleria-fs.php line 789 to:

    foreach ($enabled['hidden'] as $id => $service) {

    however they don’t seem to work.

    Plugin Author pdamsten

    @pdamsten

    Have you enabled services in Settings -> Sharing?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Sharing Buttons not showed but Jetpack installed and configured’ is closed to new replies.