The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

Fullscreen Galleria
Sharing Buttons not showed but Jetpack installed and configured (7 posts)

  1. phalanx80
    Posted 3 years ago #

    i've some problem with sharing button, it seems not working instead Jetpack is installed and sharing tool is active and configured, i've tried to set Jetpack sharing tools active everywhere (Pages, Articles and so) but still nothing except for permalink button.
    As you can see in this picture http://www.eleonorapecorella.it/developer.jpg
    the sharing div seem to be active but
    <ul> item is empty! Someone knows how i can solve it? this stuff drive me crazy :-)
    in this other picture there is my plugin configuration
    and as you can image the website affected is http://www.eleonorapecorella.it

    Thank you in advance!

  2. phalanx80
    Posted 3 years ago #

    i've tried to show the sharing button using print sharing_display();between <ul> tag in $share but doesn't work as i want. Sharing button was displayed above my post but not in the picture overlay.
    This is the code someone have an idea? how can i force to show the sharing button in the overlay div?

    $share = '';
              # Sharing_Service is a JetPack class and it must be installed for sharing to work.
              if (class_exists('Sharing_Service') && $this->options['show_sharing']) {
                $layer_has_info = true;
                $sharer = new Sharing_Service();
          		  $enabled = $sharer->get_blog_services();
                $this->share_img_url = $val['permalink'];
                $i = 0;
                $div = '<div class="galleria-layeritem sharedaddy sd-sharing-enabled '.
                       'robots-nocontent sd-block sd-social sd-social-icon sd-sharing '.
                $share = $div.'<ul>';
        			  foreach ($enabled['visible'] as $id => $service) {
        				  $share .=  '<li class="share-' . $service->get_class() . '">' . $service->get_display( $post ) . '</li>';
                  if ($i % 2 == 0) {
                    $share .= '</ul></div>'.$div.'<ul>';
                $share .= '</ul></div>';
                $this->share_img_url = '';
            $this->json .= "{id: ".$val['post_id'].
                           ", image: '".$key.
                           "', thumb: '".$thumb.
                           "', permalink: '".$bookmark."'";
            if ($layer_has_info) {
              $this->json .= ', layer: \'<div class="galleria-infolayer">'.
                         '<div class="galleria-layeritem" style="padding-right: 20px;">'.
                         '<div class="galleria-layeritem" style="padding-right: 20px;"></div>'.$share."'";
            if ($extra) {
              foreach (array("thumbnail", "medium", "large", "full") as $size) {
                $img = wp_get_attachment_image_src($val['post_id'], $size);
                $this->json .= ", ".$size.": ['".$img[0]."', ".$img[1].", ".$img[2]."]";
            $this->json .= "},\n";
            $images[$key]['id'] = $val['post_id'];
        $this->json = rtrim($this->json, ",\n");
        $this->json .= "\n],\n";
  3. phalanx80
    Posted 3 years ago #

    i've post a duplicate thread. I edit this with my apologize...

    thanks to everyone want help me

  4. phalanx80
    Posted 3 years ago #

    i'm still here trying to solve my sharing buttons problem...
    I didn't found a way to force to show the sharing button in the right place, next to permalink. Jetpack is installed and sharing service well configured as fullscreen galleria but nothing.
    I've tryed to switch template to twenty twelve but the problem still remain.
    i've seen that on http://torturedmind.org/ the service works well, could you write me which kind of version of Jetpack you use and if you have encountered some problem like mine?



  5. pdamsten
    Plugin Author

    Posted 3 years ago #

    I have latest Jetpack (2.3.5) and I haven't encountered same problem that you have.

  6. weksiu
    Posted 2 years ago #


    as odd as it sounds, but the buttons show up after changing galleria-fs.php line 789 to:

    foreach ($enabled['hidden'] as $id => $service) {

    however they don't seem to work.

  7. pdamsten
    Plugin Author

    Posted 2 years ago #

    Have you enabled services in Settings -> Sharing?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Fullscreen Galleria
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic