Support » Plugin: Yoast SEO » Sharing Buttons Not Pulling Right Descriptions

  • I’m working on a site and the share buttons are not pulling the right descriptions.

    The site is http://babybummerscartoons.com/.

    The source in the header reads:

    <!-- This site is optimized with the Yoast WordPress SEO plugin v1.2.8.7 - http://yoast.com/wordpress/seo/ -->
    <meta name="description" content="Baby Bummers Cartoons - by Devon Wickens"/>
    <link rel="canonical" href="http://babybummerscartoons.com/" />
    <link rel="next" href="http://babybummerscartoons.com/page/2/" />
    <meta property='og:locale' content='en_US'/>
    <meta property='og:title' content='Baby Bummers Cartoons - by Devon Wickens'/>
    <meta property='og:description' content='Baby Bummers Cartoons - by Devon Wickens'/>
    <meta property='og:url' content='http://babybummerscartoons.com/'/>
    <meta property='og:site_name' content='Baby Bummers Cartoons'/>
    <meta property='og:type' content='website'/>
    <!-- / Yoast WordPress SEO plugin. -->

    Now scroll down and click on of the share buttons.

    Facebook pulls this as the description:
    You may use theseHTMLtags and attributes:<​a href="" title=""> <​abbr title=""> <​acronym title=""> <​b> <​blockquote cite=""> <​cite> <​code> <​del datetime=""> <​em> <​i> <​q cite=""> <​strike> <​strong>

    And Google+ pulls the navigation:
    Home · About · Contact · Archive · E-Cards · Birthday · Congrats · Engagement · Graduation · Life Milestone · New Baby · New Job · Wedding · Holidays · Christmas · Easter · Father's Day · Halloween · ...

    What am I missing…?

    http://wordpress.org/extend/plugins/wordpress-seo/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hold on. I found another instance of OG tags below in the head of the HTML just hidden away. That’s probably the issue. I think they’re being generated by the ShareThis plugin. I will try disabling and getting back to you guys. Sorry for the inconvenience if this does end up solving the issue.

    Ok I fixed it for the most part. I still get these from the Facebook share buttons:

    You may use theseHTMLtags and attributes:<​a href="" title=""> <​abbr title=""> <​acronym title=""> <​b> <​blockquote cite=""> <​cite> <​code> <​del datetime=""> <​em> <​i> <​q cite=""> <​strike> <​strong>

    But only on older posts. Even though I removed the line entirely from the theme. Seriously, search the source HTML. That wall of text isn’t in there ANYWHERE. Facebook must have cached the URL and description because I don’t know where else Facebook would be getting that text from. Newer posts grab the right description.

    By the way it was a “Publish to Facebook” plug-in that was broken. Not sure exactly what it was called.

    For anyone curious, yes Facebook does cache links the first time.

    I found this post which in turn lead me to Facebook’s debugger. I just ran the top level domain through once and it cleaned it all up. Awesome.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Sharing Buttons Not Pulling Right Descriptions’ is closed to new replies.