Support » Plugin: Jetpack by » Sharing Buttons Email Not Working

  • Resolved mdogano


    Hi there,
    I’m using jetpack sharing buttons all other sharing buttons like; facebook, google, linkedin, tumblr etc. are working perfectly but the e-mail and print buttons simply wont. When i click on it, it opens a new tab with the same url of the post with adding a prefix end of the url which is “?shared=email&msg=fail”.
    You might wanna try so i’m giving you a test url where you can find my sharing buttos;
    Any help is appreciated.
    Thanks in advance.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hi there,

    I’m having this issue too. Things were fine some versions ago, now send by email is not working 🙁

    Plugin Contributor Jeremy Herve


    Jetpack Mechanic 🚀

    @mdogano I had a look at your site, and it seems that one of your plugins, or your theme, is causing the issue.

    If you look at your page’s source code, you will notice that the <html> tag is opened twice.

    Could you try to disable all other plugins one by one, and switch to a theme such as Twenty Eleven, to see if that helps?
    You might want to start with your Modal / Popup Subscription Box plugin.

    @diana If you experience the same issue, could you try to deactivate all your other plugins as well?

    You might also want to check if your theme or a plugin loads an old version of jQuery, instead of using jQuery 1.8.3, that comes bundled with WordPress.

    I updated jQuery to 1.8.3 and the problem resolved. Thanks for your help.

    But another quick question, i am loading jquery through google apis, how can i use the one bundled with wp ?

    Plugin Contributor Jeremy Herve


    Jetpack Mechanic 🚀

    i am loading jquery through google apis, how can i use the one bundled with wp ?

    If you do not use any extra jQuery plugin, plugins and themes that need jQuery will automatically add it to your site for you, using the version of jQuery that comes with WordPress.

    please help me with the same issue, Unable to identify the cause of not working email share button.
    Link for my site page having this issue is :

    jquery updation issue again. I tried to resolve it with “jquery updater”
    plugin and few other functions adding at header.php and functions.php of theme(while googling) but I always get the old version of jquery. How can I load the latest version of jquery to get Email and print button work. I haven’t tried disabling all the plugins and checking one by one. Is there any other way out.

    Plugin Contributor Jeremy Herve


    Jetpack Mechanic 🚀

    @vikram kumar shah To locate the function that’s loading the old version of jQuery on your site, try switching to a different theme for a few minutes, and check if that solves the issue; if it does, you’ll want to look for the function loading jQuery in your theme’s header.php file, or in the functions.php file. Once you find that function, you can remove it and enqueue the proper version of jQuery as explained here:

    If the issue is not related to your theme, please try to disable all your plugins, one at a time, until you find the one that causes the conflict. You can then enqueue jQuery using the method I linked to above.

    If you do not feel comfortable editing PHP files, you can also contact the theme or plugin author and ask them to solve the issue.

    Loading the new theme not solving the problem So the other option you mentioned is to disable all plugins and check one by one, which sounds very tedious.

    Thanks for the help. I will disable all the plugins one by one and check for the solution.

    I am using the same theme in one of sub domain and there every things is working fine including mail and print button. So not a theme issue. I will check the plugins by the way you mentioned.

    Its resolved now, did not take much time either, the last plugin to disable was the main culprit, The The Image slider. I deactivated it and everything is fine now.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Sharing Buttons Email Not Working’ is closed to new replies.