Support » Plugin: Jetpack by WordPress.com » Sharing buttons don't work for me

  • Resolved FrankBukowski

    (@frankbukowski)


    Hi
    The Jetpack Publicize sharing buttons on my blog don’t seem to work properly. I mostly want my blog readers to be able to use the Twitter and Facebook ones.

    When I click on the Facebook sharing button of a typical blog post like
    http://www.frankbukowski.com/the-day-i-met-marilyn-monroe/
    it just opens a window onto my facebook page. I was expecting it to open a window that summarized the blog post, contained the relevant image from the blog post, and gave me a ‘share’ button to confirm I wanted to share it to the facebook page.

    When I click on the Twitter sharing button it’s slightly better, but I just get the plain title of the blog post and the url of the page pasted in the box, alongside the ‘tweet’ button. At least that’s functional, but I was hoping it would maybe paste in an image, say like a twitter card.

    If anyone could point to anything I might be doing wrong, I’d be grateful.

    Thanks

    Frank

    https://wordpress.org/plugins/jetpack/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi is there anyone out there? Asked this question a couple of days ago, no replies yet. Thanks. Frank

    Frank,

    I just tried the Facebook and Twitter sharing buttons on your site and everything seems to work properly.

    This is what I get when clicking the Facebook link.

    As for the Twitter link, the current way Jetpack uses the Twitter sharing is not set up to add an image to the tweet (I am not sure if twitter does this anyway). However, I do see the tweet ready to be posted when I click the sharing button.

    Hope this helps.

    Oh cool, hey thanks Justin, that’s reassuring. Hopefully means everyone clicking on the Facebook link will be seeing the same thing, and it’s just my computer/browser that’s playing tricks. I mainly use Chrome and I have adblock set up, which sometimes does funny things. Think I’ll try it in Internet Explorer, see if my hunch is right.

    But it’s good to know that it’s working, and you’re right about the Twitter link, I don’t think they add images to the tweets, so that’s all working fine too.

    Really appreciate you checking that out. Much obliged.

    Best

    Frank

    Yup, just checked in Internet Explorer, Justin, and it worked fine, I saw exactly the same as your screenshot. So it’s definitely only a Chrome and/or Adblock issue.

    Cheers

    Frank

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Sharing buttons don't work for me’ is closed to new replies.