Support » Plugin: Shariff Wrapper » Shariff Wrapper 4.6.1 on Debian 9 with PHP 7.0

  • (No FAQ tab in this extension website)

    I’m trying to install this extension on a WordPress 5.1 hosted with Debian GNU/Linux 9 (Stable) that provides PHP 7.0

    WordPress extensions tool avoids this extension installation because it requires PHP 7.2 or newer. REALLY?!

    A) Can you compatibilize Shariff Wrapper with PHP 7.0 please?
    B) Can you fix that incompatibility property?

    This plugin is very important to deploy secure and independent websites.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Jan-Peter

    (@starguide)

    Hi narcisgarcia,

    Shariff Wrapper should theoretically be compatible all the way down to PHP 5.2, at least the PHP compatibility check does not report any problems. Obviously we cannot test it against all kinds of outdated PHP versions. We always recommend to use a PHP version that is still on active support. Currently that is PHP 7.2 and 7.3, while PHP 7.1 is on security support. All other versions, including 7.0, already reached end of life.

    Starting with WordPress 5.1, WordPress will disable the possibility to automatically install our plugin on sites with untested PHP versions. This is the desired behavior to protect non-technical users. However, you can still install the plugin manually by downloading it from https://wordpress.org/plugins/shariff/ and upload it using the “upload plugin” button in your WordPress installation.

    Since I only had the time to test it against PHP 7.2 and 7.3 until now, 7.2 is the minimum requirement for automatic installation. I’ll might lower it soon to 7.1, as soon as I had the time to test it, but won’t bother for other old and outdated versions. If somebody doesn’t bother to update their PHP versions (or change their hoster), they’ll have to upload it manually and test it themselves.

    Best regards,
    JP

    Hello Jan-Peter and thank you for replying to my fix request.

    I really don’t understand what specific features do you need not found in PHP 7.0
    PHP 7.3.1 it can also be considered EOL because PHP 7.3.2 is released (?!)

    Debian GNU/Linux is a wide used distribution, and currently stable (maintained) version is 9. It officially supports PHP 7.0 because it’s the tested and well integrated one when releasing this last stable Debian version.

    I can host you a testing website under this scenario at no cost, if it helps you with Shariff Wrapper plugin.

    Plugin Author Jan-Peter

    (@starguide)

    Hi narcisgarcia,

    you can find all information about current and older PHP releases here: http://php.net/supported-versions.php

    WordPress also offers a guide about PHP updates: https://wordpress.org/support/update-php/

    Like I said, Shariff should work with older PHP versions without any problems. The notice “PHP Version: 7.2 or higher” is merely a recommendation and a safety feature for non-technical users that states the minimum version that this plugin has officially been tested with. It works the same way as the “WordPress Version: 4.9 or higher” information.

    You can still ignore this and install the plugin manually (like you’ll have to do with all premium plugins for example) via FTP or the upload plugin button.

    Kind regards,
    JP

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.