Support » Plugins » sharedaddy share buttons not appearing

  • I activated Sharedaddy, but no share buttons are appearing on my posts
    or pages (Twenty Ten theme). On Sharing settings this is the line that I don’t understand:

    Disable CSS and JS Advanced – you must include these in your theme for Sharedaddy to work

Viewing 15 replies - 1 through 15 (of 19 total)
  • same here bro

    Have you added any sharing services?

    The ‘disable CSS/JS’ checkbox is for advanced use only – it disables the plugin’s default style and JavaScript. You don’t need to use it unless you know how to style the sharing buttons yourself.

    The button doesn’t not appear on my blog as well..

    is there a way to install button before the post?

    Same for me – Sharedaddy activated but no buttons showing up. Can anyone suggest a solution to this?

    Found a solution

    On settings page check share this on posts, pages and index

    And uncheck Disable CSS and JS.

    Worked for me. I

    Experienced a similar problem. Sharedaddy’s buttons showed up at some pages but not on others while all pages where pages with similar attributes. Found out the pages where the buttons showed up contained a custom excerpt while the others didn’t. After filling in an excerpt on a not working page the buttons showed up on the not working page as well. Hope this helps anyone.

    @wekking: Any chance you could share details to what the excerpt looks like? I’m unable to get the buttons to show on any of my pages and so I don’t have a reference to go off of. Thanks for any help!

    Any excerpt should work ( Buttons showed after inserting a line of text or inserting a blank rule <br>. ‘Show sharing buttons on this post.’ appears in the post edit screen?

    @wekking: YOU ROCK! I got it all “fixed” up and now the sharing buttons show on my posts. Here were the steps I took, in case anyone else needs some direction:

    1. Logged into my self hosted WordPress blog.
    2. Clicked on Posts.
    3. Clicked on an existing post.
    4. Clicked the Screen Options button in the upper-right corner > Checked the Excerpt box. (You only do this once and then all other posts should have the Excerpt field show up.)
    5. Went to the Excerpt field and just enter a space.
    6. Clicked Settings > Sharing.
    7. Dragged in the social media services into the Live Preview area > Save Changes.
    8. Voila! Your post has the social media buttons!

    @sonnythao: ur welcome:)

    Superb guys !! It worked like a dream.. 🙂

    Yeah. It’s not working like I dream for me because I actually USE the post excerpts whether they’re custom or not. Also, going through each post is rather tedious. I’ve tried making minor edits to the post and then updating without changing the blank excerpt to see if that helps and nothing changes.

    I’ve done some simple debugging and discovered that the problem is likely to do with how the static array shared_with_posts is setup in the sharing_display() function in the sharing-services.php file. For all pages and posts without custom excerpts, the call to isset() on shared_with_posts for the post’s ID is returning True when it should be returning False. Additionally, for a reason I’ve yet to track down, the function sharing_display() is getting called twice — well, it’s getting called twice when there is no custom excerpt. I don’t know how many times it’s getting called on posts with excerpts as my simple echo debugs are not showing up whenever the post has a custom excerpt and the sharing section is displayed.

    BTW, I’m cross-posting this to my Bug post for Jetpack as that’s how I’m using the Sharedaddy plugin.

    Thanks for the technical explanation and making a bug post. Hope the developers fix the issue in a future release.

    If anyone is using the ‘ShareDaddy’ plugin for their self-hosted blogs I have finally had success with it.

    First I edited the plugins ‘sharing-service.php’ files to remove the following lines: (you can find them right at the bottom of the file)

    add_filter( 'excerpt_length', 'calculate_excerpt_length' );<br />
    add_filter( 'the_excerpt', 'sharing_display', 19 );<br />
    add_filter( 'the_content', 'sharing_display', 19 );

    The next bit is dependant on your theme files but somewhere you should have a ‘loop.php’ where your theme builds each post. Find this file and insert the following code wherever you want the ShareDaddy line to appear.

    <?php echo sharing_display(); ?>

    That should work. All the options in the settings page will still work, but this way you don’t need to fiddle around with excerpts! Plus this way you have control over where it goes… realistically this plugin should never have been released without such a basic option!

    Hope this can help some of you.

    If anyone would like to see it in action check out my site at 🙂

    That worked! Now, if I could just get the sharing display to display properly. Sometimes it shows all the buttons and sometimes it doesn’t. It seems to be rather random when it does this. Sometimes the label “Share This:” doesn’t even show up. So, I’m thinking there’s still some bugs to be worked out with this module.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘sharedaddy share buttons not appearing’ is closed to new replies.