Support » Plugins and Hacks » [Resolved] Shared link gives 404 error

[Resolved] Shared link gives 404 error

Viewing 9 replies - 1 through 9 (of 9 total)
  • I am also having this problem…

    Does this link work: http://www.playmoparts.nl/wishlist/?user_id=1

    Nice, that works!
    Now I have to find out where to change it. I Will look into it later this evening.
    Many thanks!

    Trevor, you can change the & to ? in your share.php (line 15). Its in the template folder of the plugin.

    Changing the & to ? works fine. Please do it in the template folder to make it update proof.



    Hi. I’m having the same problem and would also like to know where I can change the code to update this. I don’t see a share.php file. Any ideas?

    EDIT: Oh.. THERE it is!

    The problem only occurs when you change the permalink settings from standard to something else. Am I right? If so, it’s a bug. I found out when setting up a second install to test some things.



    Possibly — I’m not sure. I’ve had my permalinks set to “post name” before I installed the plugin, and haven’t changed it since.



    But, in case anyone is wondering…

    In plugins/yith-woocommerce-wishlist/templates/share.php

    …I changed:

    { echo YITH_WCWL_UI::get_share_links( $yith_wcwl->get_wishlist_url() . ‘&user_id=’ . get_current_user_id() ); }


    { echo YITH_WCWL_UI::get_share_links( $yith_wcwl->get_wishlist_url() . ‘?user_id=’ . get_current_user_id() ); }

    And this resolved the problem.

    Here’s what I did. Essentially does the same thing but makes sure it works with multiple url args

    { echo YITH_WCWL_UI::get_share_links( add_query_arg( 'user_id', get_current_user_id(), $yith_wcwl->get_wishlist_url() ) ); }
Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] Shared link gives 404 error’ is closed to new replies.