Support » Plugin: BackWPup - WordPress Backup Plugin » Shared Hosting Limitations – tell us what to do pls!

  • Resolved titush


    Hi Caspar & team,

    you always mention the “shared hosting issue” in the forums, yet I have not seen a recommended hosting setting in any of your posts.

    I have a VPS and can modify most settings in the php.ini, for example I made the following changes to a web site the size of which is around 300 MB:

    upload_max_filesize = 128M
    post_max_size = 128M
    max_execution_time = 360
    memory_limit = 256M
    max_input_vars = 5000
    max_input_time = 120

    I still get the:

    “WARNING: Job restart due to inactivity for more than 5 minutes”

    message and am a little frustrated… Maybe you can tell us what settings should be done so that these “WARNING” messages disappear?


Viewing 8 replies - 1 through 8 (of 8 total)
  • What other symptoms are there, perhaps with WordPress or other plugins?

    Other symptoms with BackWPUp? Are you getting “WordPress database error MySQL server has gone away for query” messages?

    Do you have BackWPup configured to use compression (zip, gzip, tar)?

    Does WordPress Update work successfully?

    What version of PHP do you have? There are (older) versions of PHP that have bugs with zip/unzip, hang with no error messages — and make WordPress Update fail, make BackWPup compression fail, anything using zip/gzip. has PHP code that demonstrates the bug isn’t in WordPress.

    I no longer saw the “inactivity” warning after disabling BackWPup compression. Obviously the fix for this is 1) you update PHP if you have a version that has this bug or 2) WordPress itself test for the bug and use a WP version of zip/unzip or 3) don’t use BackWPUp with compression.

    BackWPUp works with compression after talking to my hosting provider; they already had a newer PHP installed, a .htaccess configuration change switched me to the newer PHP.

    Thanks for your reply George, however I don’t think any of your suggestions apply. Below are some details of the server configuration, I don’t think the PHP version is too old, quite frankly… What do you make of this?

    Using BackWPUP without compression is not an option for me, then I’d rather change the plugin as this would be self-defeating to the cause…


    WordPress version 3.6.1
    BackWPup version 3.0.13 Get pro.
    PHP version 5.4.8
    MySQL version 5.1.66-0+squeeze1
    cURL version 7.21.0
    cURL SSL version OpenSSL/0.9.8o
    Server self connect: Response Test O.K.
    Server Apache/2.2.16 (Debian) mod_fcgid/2.3.6 mod_ssl/2.2.16 OpenSSL/0.9.8o mod_perl/2.0.4 Perl/v5.10.1
    Operating System Linux
    PHP SAPI cgi-fcgi
    Disabled PHP Functions: shell_exec, popen, pclose, proc_open, proc_close, proc_get_status, proc_nice, proc_terminate, passthru, show_source, escapeshellcmd
    Loaded PHP Extensions: Core, PDO, Phar, Reflection, SPL, SimpleXML, bcmath, bz2, calendar, cgi-fcgi, ctype, curl, date, dba, dom, ereg, exif, fileinfo, filter, ftp, gd, gettext, hash, iconv, imap, json, libxml, mbstring, mcrypt, mysql, mysqli, mysqlnd, openssl, pcre, pdo_mysql, pdo_sqlite, posix, pspell, session, shmop, soap, sockets, sqlite3, standard, sysvmsg, sysvsem, sysvshm, tidy, tokenizer, wddx, xml, xmlreader, xmlrpc, xmlwriter, xsl, zip, zlib

    With PHP 5.4.8, and you not mentioning “WordPress Update hangs”, I would say you do not have the PHP Zip/Unzip problem.

    When I’ve gotten “MySQL server has gone away for query” is when I’ve gotten “Job restart due to inactivity”, but you don’t say you’ve gotten that error.

    No other ideas.

    Hi Geroge, no worries….
    No, the only message I get is that inactivity message. Also, the job takes up loads of memory and it just seems awfully slow to zip a few hundred megs on an otherwise quite quick server…

    I think there is something that’s making it hang, not sure whether it’s a single file that’s too big to be zipped in one go, or something else like a file it can’t read or so… It just feels odd. When I zip that folder on my i3 notebook, it takes less than 40 seconds, so I wouldn’t expect this to take more than 2 minutes on my dual core server..

    Anyway, if you need some testing done, I am happy to help out. I love your plugin and would really like to be able to use it more extensively…




    just read this post and I have to say I’ve got the same problem with the new version BackWBup 3.0.13. The job is very slow and it tooks a long time. And in between I have seen the message the job was started new due to inactivity of more than 5 minutes.

    Do not know what to do!
    I run wordpress 3.6.1
    The job is running with compression



    Hello have you tried the Beta version 3.0.14? They have fixed many issues and improved the performance of the plugin.

    Kind regards



    Just to chime in here (I opened this thread):

    I have been trying this on a local server (WAMP) and it takes ages to back up. I then tried xcloner which backs up my 70MB site in less than 10 seconds:

    This shows me that it’s not a “server limitation”, but something in BackWPUp that is causing these delays.

    Just an FYI for who doesn’t want to wait for BackWPUp to address this. I actually now use XCloner standalone and have set-up a cron job to FTP the backup to a location every day. Works like a charm and is very reliable (XCloner is free as well, by the way).

    I still prefer BackWpUp with regards to the numerous aspects of customization it offers but with backups it’s really just about getting the job done as a base requirement 🙂




    @wbwp: What version of PHP do you have? BackWPup Settings /wp-admin/network/admin.php?page=backwpupsettings on the Information tab has “PHP version”.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Shared Hosting Limitations – tell us what to do pls!’ is closed to new replies.