WordPress.org

Forums

Share This plugin - Weird pop-up in IE Browsers..Firefox fine (16 posts)

  1. FreshPeel
    Member
    Posted 7 years ago #

    I installed the ShareThis plugin and everything works as it should in all browsers except IE 7 & 6. In IE, the farther you go down the page, the ShareThis popups show up on screen way down the page away from the articles that they are associated with.

    To understand what I'm talking about, go down to the bottom post on the page at http://www.freshpeel.com and click the Share This link (I changed the icon).

    Please help before I have to spend some good money to fix this. I really like this plugin and would very much like to get it working.

  2. whooami
    Member
    Posted 7 years ago #

    start by fixing the structural errors affecting your validation.

    http://validator.w3.org/check?uri=http://www.freshpeel.com/

  3. FreshPeel
    Member
    Posted 7 years ago #

    Wow. That's a lot of errors. I will start trying to correct them.

  4. FreshPeel
    Member
    Posted 7 years ago #

    I'm still getting a few errors, but it looks like most of them are associated with items in the post and not the structure of the page.

    (I do however have some errors around my RSS feed icons and links, so if someone could help me there I would be grateful.)

    As far as the Share This problem. I'm still having the same problem. Any ideas?

  5. FreshPeel
    Member
    Posted 7 years ago #

    Any thoughts? Or am I going at it alone?

  6. FreshPeel
    Member
    Posted 7 years ago #

    Here's a screen shot of what the problem looks like: ShareThis pop-up screen shot

  7. 4k
    Member
    Posted 7 years ago #

    Do you have a footer file? Have you tried putting <?php akst_share_form(); ?> in your footer code?

  8. FreshPeel
    Member
    Posted 7 years ago #

    There is a setting in the plug-in options to put that piece of code into the footer. Just to make sure it is putting it in right I did it manually, and the results were the same.

  9. FreshPeel
    Member
    Posted 7 years ago #

    It seems like the fact that the pop-up gets farther away the further down the page you go should mean something, but what I don't know. I've been looking at structure, but I can't figure out why it would come up this way in IE... and be perfectly fine in Firefox, Safari, etc.

  10. FreshPeel
    Member
    Posted 7 years ago #

    I found another blogger that's having the same problem. They may not even know it. Here's the address if you want to test it in IE: http://nostatus.com/

  11. FreshPeel
    Member
    Posted 7 years ago #

    At this rate I may have to end up hiring the great Alex King to fix this problem after all.

    I've been posting in quite a few other WP forums and no one really has any clue.

  12. FreshPeel
    Member
    Posted 7 years ago #

    Maybe the code: <?php akst_share_form(); ?> could load only if it's not IE. Does anyone know how that might be done?

  13. FreshPeel
    Member
    Posted 7 years ago #

    Well I guess I'm going to turn this function off and just make it pop up full screen since I can't get it resolved. I didn't have much luck w/ the IE hack.

  14. aroxo
    Member
    Posted 7 years ago #

    Yep. Have the same problem on http://www.aroxo.com/blog/mattr.

    However, I have the opposite. It works in IE, but not in The Fox. Grrr.

    Did anyone ever get anywhere with it?

  15. aroxo
    Member
    Posted 7 years ago #

    ...Stop press....Stop press...

    Fixed.

    Pop into your admin console, then options, then gregagious, then "Post badge", then remove the <%share%> and <%reddit%> and they shall disappear.

    What I think happens is that when Gregarious we must have set it up to display share and reddit tags. Then when we removed them, it doesn't update the code - hence the problem.

    However, that should sort it.

    M.

    http://www.aroxo.com/blog/mattr

  16. dlature
    Member
    Posted 7 years ago #

    I see freshpeel never got his problem with the IE popup window location resolved. It is definitely a theme issue. I use K2, and when I revert to the default theme, the popup appears in the correct place (directly below the share this link just clicked, and this works all the way down the page as you scroll down to posts further down the page.

    Can someone PLEASE sharre what one needs to do to get the correct popup behaviour into a theme. If I could just get the correct javascript for the click event on the share this link, that would be great, then I could place it in the js files called by K2.

Topic Closed

This topic has been closed to new replies.

About this Topic