Support » Plugin: WordPress Social Sharing Plugin - Sassy Social Share » share links stopped working

  • Resolved fgilbane

    (@fgilbane)


    Hi:
    The only Share link that works is the email link. It happens on all my posts. I have tried with Safari and Chrome on desktop and iOS. I have the latest versions of all plugins and of WordPress. I am not sure when the problem started, but it is fairly recent.
    Thanks

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Heateor Support

    (@heateor)

    Hi there,

    It’s because your JS minify plugin is breaking the Javascript of this plugin. You can try excluding following JS file from the minify:
    wp-content/plugins/sassy-social-share/public/js/sassy-social-share-public.js

    fgilbane

    (@fgilbane)

    Thank you!
    I tried to exclude that script in WP Rocket and that didn’t work. But when I disabled all JS magnification the problem went away. I have left all JS magnification off for now and will follow-up with WP Rocket about the specific exclusion not working.

    Plugin Author Heateor Support

    (@heateor)

    You’re welcome. Do let me know if you have any suggestions/improvements regarding this from WP Rocket.

    fgilbane

    (@fgilbane)

    Hi:

    Everything is working now except on Safari on my iPhone pro 11 with iOS 3.2. See 1) below.

    I tried excluding the script you sent but it didn’t help. I then turned off all JS minification and everything worked (including another problem not necessarily connected to Sassy, but occurred around the same time, where my hamburger menu links had stopped working). WProcket then looked into it got it to work with excluding a Sassy inline script, see 3), and jQuery, see (4.

    Relevant correspondence with WProcket:

    1)
    ME: On MacOS the hamburger menu and sassy social sharing both work fine on Safari, Chrome, and Firefox. On iOS they both work fine on Chrome and Firefox, but on Safari Sassy Social buttons *don’t work*, but the hamburger menu does.
    WPROCKET: Hm, I can’t reproduce this issue as yet. Could you make sure you’re testing in an incognito browser window and/or clear your browser cache so we can make sure you’re testing on the latest version of the site.
    Which specific iOS device are you using? I’ll try to replicate the same conditions to see if I can spot the error that way.
    ME: I still can’t get it to work on iPhone Pro 11, but it *does* work fine on my iPad Pro. If you still can’t reproduce it on an iPhone I’ll try a couple of more things and then report to Sassy and Apple.

    2)
    ME: I noticed you didn’t exclude the script that Sassy Social Share initially suggested I try and exclude (wp-content/plugins/sassy-social-share/public/js/sassy-social-share-public.js). I assume that it had no effect?
    WPROCKET: Indeed, that didn’t seem to make any difference that I could see. However, I just added it back to the exclusions, in case it’s causing the iOS issue that you’re seeing. Let me know if that makes any difference.
    ME: Still works fine. Don’t see any other issues.

    3)
    ME: What does the string you excluded from inline JS concatenation (heateorSssHorizontalSharingCountEnable) do?
    WPROCKET: There is an Inline JS script related to sassy social share which needs to be excluded from Combine JS.
    This is the whole script: https://jmp.sh/qTfDH9g
    That string is just a way to identify the script to exclude it. You could use any unique string from within the script to identify it for exclusion.

    4)
    ME: Which problem did the exclusion of /wp-includes/js/jquery/jquery.js address?
    WPROCKET: This is related to sassy social share. The above inline script relies on Jquery. If Jquery is included in the combined file it’s loaded too late – the inline script is already asking for it and it creates an error.

    Plugin Author Heateor Support

    (@heateor)

    ME: Which problem did the exclusion of /wp-includes/js/jquery/jquery.js address?
    WPROCKET: This is related to sassy social share. The above inline script relies on Jquery. If Jquery is included in the combined file it’s loaded too late – the inline script is already asking for it and it creates an error.

    You would like to try toggling the Load Javascript files in footer option in “Miscellaneous” section at plugin options page in admin to check if this makes any difference.

    Thank you. Toggling the Load Javascript files in footer worked in every case but one. It works on Desktop with Safari, Chrome, Firefox, and Brave. And it works on Chrome and Firefox mobile, but *not* in Safari mobile on my iPhone 11 Pro running 13.2 or earlier versions of 13. But, t *does* work on my wife’s iPhone 7.

    I noticed there were two “Toggling the Load Javascript files in footer” options in the Miscellaneous section that looked identical, so I toggled both.

    Plugin Author Heateor Support

    (@heateor)

    Toggling the Load Javascript files in footer worked in every case but one. It works on Desktop with Safari, Chrome, Firefox, and Brave. And it works on Chrome and Firefox mobile, but *not* in Safari mobile on my iPhone 11 Pro running 13.2 or earlier versions of 13. But, t *does* work on my wife’s iPhone 7.

    It seems some compatibility problem with these browsers. Will check and keep you posted.

    I noticed there were two “Toggling the Load Javascript files in footer” options in the Miscellaneous section that looked identical, so I toggled both.

    Yes, it’s a bug. There should be only one of these options. We will fix it in upcoming releases.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.