WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Share by Email not working

[Resolved] Share by Email not working

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author Jeremy Herve
    Participant

    @jeherve

    Could you try to switch to a different theme like Twenty Eleven, and see if that helps?

    • Your current theme seems to include 2 different versions of jQuery: one that’s bundled with WordPress and added into wp_head
    • One that’s added into your theme’s header.php file

    I also noted that your wp_footer(); call is placed after the closing </html> tag. Could you open your theme’s footer.php file, and move wp_footer right before the closing </body> tag?

    The Wp footer change solved it. Thanks, Jeremy! You can see the site in action here : http:://blog.rockwoodleadership.org

    Keith
    Member

    @tsudohnimh

    Jeremy – I was wondering if you could take a look at my blog and see why I’m experiencing the same issue? Thank you in advance.

    Samantha Yee
    Member

    @samantha-yee

    Hi Jeremy,
    Likewise, I’m having the same problem at http://www.invitroinnovation.com. Appreciate your advice – have already checked the wp_footer call and it appears to be in the right place. Thanks in advance!

    Plugin Author Jeremy Herve
    Participant

    @jeherve

    @keith Could you try to deactivate the Twitter Anywhere plugins you have installed on your blog? If that doesn’t help, could you try to deactivate W3 Total Cache?

    @samantha your theme, “Modular”, uses an old version of jQuery. If you switch to a different theme or make sure that your current theme uses the version of jQuery that is included in WordPress, the problem should disappear.

    Keith
    Member

    @tsudohnimh

    @jeremy – Thank you. I’ve disabled both and I still can’t get the email sharing to work. Any other ideas?

    reflectiondigital
    Member

    @reflectiondigital

    I had this issue also. I noticed that 2 files were giving errors in the Javascript console ‘gprofiles.js’ and a Javascript file from my theme. After disabling the theme js file, I went to Settings > Discussion and unchecked “View people’s profiles when you mouse over their Gravatars”. Now it’s working.

    Plugin Author Jeremy Herve
    Participant

    @jeherve

    @keith

    I had another look at your site, and it seems to be using an old version of jQuery.

    <script data-cfasync="false" src="//ajax.googleapis.com/ajax/libs/jquery/1.7.2/jquery.min.js"></script>

    I would recommend that you switch to a different theme, and try deactivating all your plugins, one at a time, in order to find out which includes this old version of jQuery into your posts.

    I would start with the plugin handling the “Kudos” on the site.

    Let me know if this helps.

    notawoodpecker
    Member

    @notawoodpecker

    Guess I have to add mine in here too since this started popping up. I’d really rather not change themes though.

    http://thetarnishedbadge.central-us.net/wordpress/

    After disabling the theme js file, I went to Settings > Discussion and unchecked “View people’s profiles when you mouse over their Gravatars”. Now it’s working.

    I just unchecked that option, but I have no idea how to disable the theme js file.

    Plugin Author Jeremy Herve
    Participant

    @jeherve

    @notawoodpecker The Email button seems to work just fine on your site; I just tried to share your latest post, and I received an email within seconds. Have you managed to solve the issue by yourself?

    notawoodpecker
    Member

    @notawoodpecker

    The only thing I did was uncheck the setting about Gravatars as noted above.

    I see the indication of a successful share in SlimStats now about an hour and a half ago, but that’s the first time I’ve seen that. Everything else showed the error.

    Maybe the Gravatar setting corrected it as the other poster noted.

    notawoodpecker
    Member

    @notawoodpecker

    Errors still appearing, but apparent successes too. Watching for further patterns.

    Plugin Author Jeremy Herve
    Participant

    @jeherve

    I just tried again, and could share 3 of your posts without any problem.

    When you try to use the button, do you see any errors? Does the success message appear upon hitting the “Send Email” button?

    notawoodpecker
    Member

    @notawoodpecker

    My test succeeded, but I continue to get this and the Hit # is increasing.

    /wordpress/?shared=email&msg=fail 7,44% Hits: 309

    Maybe something the user is doing. Have no idea.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[Resolved] Share by Email not working’ is closed to new replies.