WordPress.org

Support

Support » Plugins and Hacks » Jetpack by WordPress.com » [Resolved] Share Buttons Showing but Not Working

[Resolved] Share Buttons Showing but Not Working

  • My current theme has built-in social media integration, but I prefer jetpacks options so I’m using the share buttons through publicize. The buttons are showing up on my pages and posts, but when clicked, they reload the blog page rather than redirecting to facebook, pinterest, or twitter.

    I’ve tried changing the “open links in” setting, changing the button styles, and switching themes, but the problem persists.

    Right now I still have my theme’s sharing buttons activated because I don’t want to deactivate them until the Jetpack buttons are working correctly but I’ve tried the buttons with and without the theme buttons and the same issue happens.

    Any ideas?

Viewing 15 replies - 1 through 15 (of 41 total)
  • Plugin Author Jeremy Herve

    @jeherve

    Could you post a link to your site so I can have a look?

    You might also want to check if your theme uses the correct version of jQuery, that comes bundled with WordPress. Some themes deregister jQuery and use their own outdated version, and that can create such issues.

    Hi Jeremy — Thanks for the response.

    The link to the site is
    http://www.adventurestonowhere.com

    Take a look at any of the posts to see the issue. Right now I still have the share buttons built into my theme activated because the publicize ones aren’t working. I’ve tried getting them to work with and without the buttons from my theme and the same problem persists. I click the share button and the page reloads back to the blog page.

    I will try and figure out how to check on the jQuery version this evening. I’m using the Sexy Thrilling Theme and I’ve gone to other sites using this same theme and the publicize share buttons work.

    Thanks again.

    I am having a similar problem on TheCubanReuben.com. My subscribe link doesn’t work.

    Plugin Author Jeremy Herve

    @jeherve

    @kskwared Try removing the call to an old version of jQuery in footer.php, in your theme folder; that should solve the problem.

    @jlstempel I used the sharing buttons and subscribed to your site using the Subscription widget in your sidebar; everything seems to be working properly on your site. Have you managed to find a solution by yourself?

    Yes, Jeremy. Thanks. I was able to figure it out on my own. It turns out that I moved the widget to the wrong area.

    @jeremy – I deleted the old version of Query. Now a new window pops up and loads, but instead of loading facebook or pinterest, it reloads my page into a new window….So it appears that is an improvement, but still not taking me to the share site.

    Plugin Author Jeremy Herve

    @jeherve

    Could you try to disable all other plugins one by one, and see if one them conflicts with Jetpack Sharing buttons?

    Hi ! I have the same problem with the email and print buttons on Jetpack – they are there but don’t work (just return the same page with an error message) – is there somewhere to configure them ? http://www.mplanes.com
    Any help much appreciated.

    Plugin Author Jeremy Herve

    @jeherve

    @fastjay4 Your theme also uses an old version of jQuery (1.6.1). Removing it should solve the issue.

    You can read more about it here:
    http://wordpress.org/support/topic/troubleshooting-wordpress-35-master-list?replies=4#post-3547424

    hi Jeremy, thanks a lot for your help. I first went to the link and followed the instructions but no change. For info it is the same problem on Safari and Firefox and I added the script_debug line and still nothing.
    I suppose if deleting jQuery is the answer, how do I do this ? Is it a plugin ? Sorry for the simple questions but I’m not a programmer …

    Plugin Author Jeremy Herve

    @jeherve

    You’ll want to look for the function loading jQuery in functions.php, in your theme folder, or in the header.php file.

    If you do not feel comfortable editing your theme files, I would suggest that you contact the theme author about it.

    I am ok editing files as I’ve done it before but I need to know which lines to delete. In header.php there are 17 references to jQuery beginning:

    <script type=”text/javascript”>
    // initialise plugins
    jQuery(function(){
    // main navigation init
    jQuery(‘ul.sf-menu, nav.primary .menu’).superfish({

    In the functions.php there is only this reference to jQuery:
    //Loading jQuery and Scripts
    require_once $includes_path . ‘theme-scripts.php’;

    Can you suggest what I need to do ? Thanks

    Plugin Author Jeremy Herve

    @jeherve

    In the functions.php there is only this reference to jQuery:

    //Loading jQuery and Scripts
    require_once $includes_path . 'theme-scripts.php';

    That seems to indicate that your theme loads scripts from a file named theme-scripts.php, placed in subdirectory of your theme (maybe inc/, includes/, or functions/)

    Could you check that file, and look for a function calling jQuery?

    Thanks for your quick reply, sorry for being slow in responding 😉
    Yes the theme-scripts.php is full of jQuery and it begins like this:

    <?php
    function my_script() {
    if (!is_admin()) {
    wp_deregister_script(‘jquery’);
    wp_register_script(‘jquery’, get_bloginfo(‘template_url’).’/js/jquery-1.6.1.min.js’, false, ‘1.6.1’);
    wp_enqueue_script(‘jquery’);

    After this, every line has jQuery in it ….

    Plugin Author Jeremy Herve

    @jeherve

    Can you delete that function? That should solve your issue.

Viewing 15 replies - 1 through 15 (of 41 total)
  • The topic ‘[Resolved] Share Buttons Showing but Not Working’ is closed to new replies.
Skip to toolbar