Support » Plugin: Social Media Feather | social media sharing » Share buttons not showing up on posts or pages

Viewing 10 replies - 1 through 10 (of 10 total)
  • I see you’re using WP Super Cache, have you cleared all caches after enabling those options?

    I think the problem is on synved-social-setup.php around line 823:

    if (!$exclude_share && synved_option_get('synved_social', 'automatic_share_single'))
                    {
                            $exclude_share = !is_singular($id);
                    }

    Should be

    if (!$exclude_share && synved_option_get('synved_social', 'automatic_share_single'))
                    {
                            $exclude_share = !is_single($id);
                    }

    Or you could use is_singular($post_types) but that takes some more code wrangling.

    mickey

    P.S. Next can we control if the share buttons show up before the_content, after, or both?

    Y

    It would be good if we could get an update which incorporates this fix if the line of code referenced is correct. I am unable to edit the code of my theme.

    is_single wouldn’t work as that’s only useful for posts, not pages. I have a more proper fix in my local development branch but it should still work, as both post and page are checked by default from is_singular, so it might not fully fix this particular user’s problem. In any case if that’s the culprit as I said it’s already fixed and will be in the next version.

    I’ll think about positioning options, although that’s highly dependent on the theme in use and putting things at the beginning of the post/page might actually screw things up.

    I agree, is_single is a hack and only works for posts, but is_singular($id) does not work at all. Ideally, as I mentioned, I’d use is_singular($post_types), but that’s a bit too much work for me right now 🙂 Is_singular() (with no argument) should work for pages and posts, but not CPT.

    I’m looking forward to your fix. Thanks for your help and work!

    mickey

    Please try update to 1.3.0 and let me know if it fixes those issues.

    This seems to work when showing icons automatically; however the theme code does not work for me still.
    synved_social_follow_markup();
    or
    synved_social_share_markup();
    mickey

    This issue has to do with automatic appending not working so I’m not sure what you’re referring to.

    I’ll start a different forum topic when I’ve had a chance to investigate some more.thanks.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Share buttons not showing up on posts or pages’ is closed to new replies.