Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support shareaholicgreg

    (@shareaholicgreg)

    Hi there – let me know if you’d like to try and get these working again. If you install Shareaholic on the site I can take a look and try to diagnose this for you.

    Common reasons for the buttons disappearing include:
    – Accidentally deactivating Shareaholic or turning off the “share location” where the buttons were appearing
    – Installing a conflicting plugin, for example caching plugins which can interfere with Shareaholic (this is usually easy to fix)

    Best,
    Greg

    I would like to try to get the Shareaholic plugin working again.

    I was hoping after all of the recent updates it would start working again. No luck.

    I especially like the related content.

    I have reactivated the plugin and currently have share buttons selected for below index and below post.

    Index: https://www.currentinspiration.com/dose-of-inspiration/
    A Post: https://www.currentinspiration.com/feed-your-soul/announcing-the-new-cultivate-your-life-app/

    For cache, I recently switched from WordFence Falcon to Yoast’s W3TC. I also use CloudFlare. But I have been using CF for a long time with Shareaholic working correctly.

    My newest addition is W3TC. Tried clearing all caches. Still no luck

    Plugin Support shareaholicgreg

    (@shareaholicgreg)

    Hi @bb-4,

    Can you please try this: Go to your settings for W3 Total Cache and DISABLE the feature for “Minification” and see what that does, and let us know here when you’ve done it?

    The issue almost certainly has to do with one or multiple of the WordFence, CloudFlare, and W3TC plugins, which can freeze elements of the page and prevent communication with outside services like Shareaholic.

    Thanks,
    Greg

    Hi Greg,

    Thanks, its working now.

    I turned off the W3TC minify. This worked and the share buttons came back, but my page load time doubled.

    I got the share buttons to work with minify enabled with these W3TC settings:
    Minify mode: Manual
    Minify cache method: Disk
    HTML minifier: Minify (Default)
    JS minifier: Goolge Closure Compiler (Web Service)
    CSS minifier: Minfy (Default)

    I also had MailMuch forms stop working. These changes also fixed the MailMunch forms.

    🙂

    Plugin Support shareaholicgreg

    (@shareaholicgreg)

    Great! Thanks for sharing those custom settings for others to see, too.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Share buttons dissapeared’ is closed to new replies.