Shadowbox JS
[resolved] Shadowbox not working on homepage? (3 posts)

  1. Cole Geissinger
    Posted 4 years ago #

    Hello, I have been using Shadowbox for quite sometime but this is my first time using the plugin for WordPress.

    I have a swf I'm trying to get to open in SB on the homepage, but it won't run, it just opens directly to the file? I have all the proper formatting in the rel attribute, although I am trying to load SB in a link in the Nivo Slider (hand added, not the plugin).

    If I enable Smart Loading it won't load the script in my footer (wp_footer() is there). So I need to disable Smart Loading for the script to load there, which seems odd to me because my understanding is that with Smart Loading it would detect this but it isn't. It's working everywhere else, but the homepage. I don't get any JS errors, and I've tested with Chrome, Firefox (4), Safari and opera on the mac and can't seem to see why it's not working.


    any feed back will be much appreciated :)
    - Cole

  2. Matt Martz
    Plugin Author

    Posted 4 years ago #

    Nothing appears to be wrong with shadowbox. Something else on the page may be conflicting with shadowbox. The slider on the page makes troubleshooting difficult from my end.

    My advice, disable the slider and test again. If it still doesn't work disable all other plugins and test again.

    As far as "Smart Loading" is concerned. It will intelligently load shadowbox if it finds shadowbox in the rel attribute of the content of a post. It doesn't appear as though that anchor tag is in the content of a post.

  3. Cole Geissinger
    Posted 4 years ago #

    Thanks for taking a look at it. I'm thinking maybe the slider is conflicting with it :/
    I'll continue to debug this, at least now I have things narrowed down :)

    Thanks again!!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Shadowbox JS
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.