Support » Plugin: SG Optimizer » SG optimizer not showing image preview on Whatsapp…

  • Resolved hbk747

    (@hbk747)


    Hi, I used to use Optimole for image optimization but around a week back uninstalled it and started using SG optimizer’s image optimization. I have “new images optimization” enabled and have also optimized the existing images in my media library. I have also generated web p copies of news images and existing images. For lazy load media, lazy load iframes, lazy load videos, and lazy load for mobile are turned on.

    I have two issues 1) Since I started image optimization on SG optimizer, the article preview that one gets when one shares an article on Whatsapp has disappeared. Before as soon as I used to copy paste a link from my website, the preview (image thumbnail) would appear and everything but now only the link shows and nothing else. I read a thread that another person had the same issue with SG optimizer.

    2) This is a general thing but how can I tell if my images (new and existing) ARE being optimized and also if webp copies are being generated? Is there a website that I can use to check? Or could you kindly just let me know? I just want to make sure the optimization process is working

    Please help.

    Thank you

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Stoyan Georgiev

    (@stoyangeorgiev)

    Hello there @hbk747,

    Regarding the first issue, we will look further into it, as this may be caused by WhatsApp itself. I did try to send a link with your articles via WhatsApp, but indeed there was no preview. I have tested it with a site with a similar setup of the SG Optimizer and I got the preview right. I will give you additional information on the issue when we investigate the exact reason. Would it be possible to purge the Cloudflare cache if you are using it, and also can we disable the SG Optimizer for a limited period of time, so we can check if the issue is indeed caused by the plugin?

    As for the second issue, which is more of a concern. I did a check and there are generated webP copies of your images. You can check that by opening your File Manager in Site Tools, navigate to wp-content->uploads->2020->12. There you can see all of the optimized images as well as their webP copies.

    Kind Regards,
    Stoyan

    Thread Starter hbk747

    (@hbk747)

    I am not sure if this is a Whatsapp issue as other links seem to be working fine on Whatsapp (local websites as well as international ones). I will try clearing the Cloudflare cache as u suggested. Yes, you can disable SGO if it will help to figure out the problem.

    Thanks!

    Edit: I have purged the Cloudflare cache but I purged it through SiteGround since I have a Cloudflare enabled through Siteground. I went to my SiteGround Cpanel then Speed > Cloudflare > Settings > Cache Purge.
    If this was correct then great but if there is some other way that you need me to do it, then please let me know.

    Edit 2: I just remembered that before turning on the Image optimization for SGO, I enabled the “Cloudflare Full Page Caching” on the SGO plugin a few days ago. I have purged cache from this page also.

    • This reply was modified 1 month, 4 weeks ago by hbk747.
    • This reply was modified 1 month, 4 weeks ago by hbk747.
    Plugin Author Stoyan Georgiev

    (@stoyangeorgiev)

    Hey there @hbk747,

    We have checked the issue you were experiencing. We will add a fix in the next version of the plugin.

    Kind regards,
    Stoyan

    Thread Starter hbk747

    (@hbk747)

    Okay great thanks.

    Hope that is soon.

    Thanks again for the great plugin support.

    Take care

    Thread Starter hbk747

    (@hbk747)

    @stoyangeorgiev

    Hello, there was finally an update but it seems the issue remains unresolved. I still see no image preview on whatsapp.

    Please help. I have been sharing my posts on whatsapp without the image and it looks really unprofessional.

    Regards

    Plugin Author Stoyan Georgiev

    (@stoyangeorgiev)

    Hello there @hbk747,

    Could you please, deauthenticate the Cloudflare Full Page Caching and then authenticate it again from the Cloudflare tab inside the plugin. After that everything should be working and sharing via Whatsapp should have the thumbnail preview.

    Could you please ping me after following the steps with the result you got, since I want to make sure you get the expected result? I will be more than glad to help you out solving the issue.

    If you have any other questions, feel free to reach back to us right away.

    Kind regards,
    Stoyan

    Thread Starter hbk747

    (@hbk747)

    @stoyangeorgiev Yes! It seems to be working now!

    Thank you so much!

    Regards

    Plugin Author Stoyan Georgiev

    (@stoyangeorgiev)

    Hey @hbk747,

    I am really happy to hear that! I am glad that we managed to help you out!

    By the way, it would be really awesome if you spend some time and leave a review of the plugin and give us any feedback in the future. It really helps us a lot.

    Kind regards,
    Stoyan

    Thread Starter hbk747

    (@hbk747)

    @stoyangeorgiev Sure 🙂

    Thread Starter hbk747

    (@hbk747)

    @stoyangeorgiev Hello I gvae u gave 5 stars but I need help again.

    The image preview never began. I know I said everything is working fine now but that was just because the title of the article/paper appears but the featured image/thumbnail still does not appear on Whatsapp. I tried some other websites and it is working for them so it is not a Whatsapp policy. I can send you screenshots of what I mean if you want. Maybe some lazy load or image optimization functionality is causing this?

    Hope to hear from you soon
    Regards

    Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    This is not something related to the SG Optimizer pluggin. Sorry but can’t help you with that. I would recommend you to contact a dev to get the appropriate meta info rendered on your site that handles such previews. I suspect it’s something like FB’s og: property but you shgould check it out yourself or with help.

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.