Support » Plugin: SiteGround Optimizer » SG-OPTIMIZER : MEDIA-WEBP NOT CONVERTING

  • Resolved dennislube

    (@dennislube)


    I have enabled “Use WebP Image ” but the converting image is 2 of 322. It has been loading for over a week now. About 2 weeks ago I deleted the SGO plugin and after a few days I install it again but the problem is still there. I only have SGO as my optimizing plugin.
    What can be the problem?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Elena Chavdarova

    (@elenachavdarova)

    Hello @dennislube,

    For WebP Image generation, we use WordPress cron. So in order to make sure the process will be completed WP_CRON should be enabled for the site. It is enabled by default, but if you have disabled it for some reason this should be reverted.

    You can check if there is something preventing the cron job from executing as well.

    Best Regards,
    Elena

    Thread Starter dennislube

    (@dennislube)

    I Submitted a ticket and my problem was Solved now Everything is working as expected.
    Thank you and be Safe.

    Plugin Author Elena Chavdarova

    (@elenachavdarova)

    I am glad the issue is resolved now, @dennislube!

    You can drop a quick review for the plugin if you have the time, that would be highly appreciated 🙂

    Best Regards,
    Elena

    I’m having the same issue trying SG Optimizer conversion to WebP getting stuck. In my case, it gets stuck on image 170, 171 or 172 out of ~345. I get “timeout waiting for output from cGI script”. I submitted a ticket and was told all of my cron jobs are starting at the same time.
    Strange. Why is this process the only thing being affected? This is confusing.

    Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    Because it’s a long process and gives enough time for other scripts to break it. We have performed multiple tests and this functionality works just fine. I suppose it’s something else throwing errors at some point of the process.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘SG-OPTIMIZER : MEDIA-WEBP NOT CONVERTING’ is closed to new replies.