Support » Plugin: SiteGround Optimizer » SG Optimizer deactives on purge

  • Resolved BobFest

    (@bob33)


    I’ve got this plugin running on half a dozen or so sites and have noticed over the past week or so (but it’s likely since the last update) that when I go to the plugin admin, the SG Optimizer is toggled off.

    I’m not using any of the other functionality of the plugin.

    Today, when I discovered this on another site, I reactivated the Dynamic caching and Memcaching then hit the Pure SG Cache link in the top admin menu and when the page reloaded all caching was toggled off.

    The same thing happens when Purging from the front end using the same link.

    In fact, just reloading the plugin admin page causes the caching to turn itself off.

    It doesn’t happen when using the ‘Manual Cache Purge’ button from within the plugin admin.

    Seems unlikely this is specific to my installs and as mentioned, I’ve only noticed this happening recently.

    As an aside, I routinely have to re-enable caching after updating the plugin.

    • This topic was modified 2 years, 9 months ago by BobFest.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Stanimir Stoyanov

    (@sstoqnov)

    SiteGround Representative

    Hey @bob33

    Would it be possible to provide your site URL?

    It seems that other plugin blocks the rest API endpoints and the SG Optimizer cannot fetch its options.

    Regards,
    Stanimir

    Thread Starter BobFest

    (@bob33)

    Hi Stanimir – let me know a way to get hold of you at Siteground.
    thanks

    Thread Starter BobFest

    (@bob33)

    FYI – I’ve just checked a site that was running version 5.3.10 and the problem is not occurring there.

    After updating to 5.4.3 the problem is present.

    This would strongly suggest to me that changes in the plugin between those versions have broken something.

    But, I’m guessing you’ve worked that out.

    Looking forward to an update that fixes this issue and makes the plugin great again.

    Plugin Author Stanimir Stoyanov

    (@sstoqnov)

    SiteGround Representative

    Please send your site url to stanimir.stoyanov[@]siteground.com

    Thread Starter BobFest

    (@bob33)

    Thanks Stanimir – will do.
    (feel free to edit out your email)

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘SG Optimizer deactives on purge’ is closed to new replies.