Support » Plugin: SG Optimizer » SG Optimizer 5.X (Persistent Warning Message)

  • Resolved jetxpert

    (@jetxpert)


    Hi there,

    After installing SG Optimizer 5.0.3, we keep getting a persistent (red) warning message at the top of our WP dashboard. We have clicked the “x”, removed all conflicts with WP-Rocket, and also purged all cache. Unfortunately, when we refresh our browser (WP dashboard) the message keeps coming back. The message appears at the top of our main WP dashboard page and the top of our plugins’ settings page.

    Click here for a visual.

    As a back-up, ticket submitted to SiteGround. Purpose of this post is to also gage the community to see if they have similar problems.

    Great plugin update, but still has a minor bug. I’m sure it will get better over time.

    Please review and fix. It’s a nagging message that just won’t go away.

    Thanks!

Viewing 15 replies - 1 through 15 (of 17 total)
  • Same problem here 🙂 I am using the plugins Autoptimize together with Async Javascript for some script optimizations. Therefore some options of SG Optimizer are redundant, but as the initiator of this thread already noted, the red message keeps on coming back and does not have a ‘dismiss’ button for example. Please fix it.

    Thanks and regards.
    Bark

    @jetxpert, yes, I experienced the same thing. A persistent warning, ours was about A3 Lazy Load. Apparently SG Optimizer conflicts with a lot of other plugins now. I had to rollback SG Optimizer to an earlier version in order to fix our website. At one point the website was completely broken, and everything fixed when I rolled back SG Optimizer, so I know that is the issue. I am not planning to update SG Optimizer for quite some time, until I can be sure they have looked into and fixed all of the issues that appear to be erupting today for users who did update. I am glad I could rollback and fix it in the short term.

    • This reply was modified 7 months, 3 weeks ago by  garrettzucker.

    Unable to dismiss the nag screen as well.

    Yep. Same problem. In my case, I use Imagify as my image compression plugin and even though I have image compression turned off in SGO, the message is persistent. Unfortunately, when I submitted a ticket to ask about the problem, Siteground’s advice was to stop using Imagify and use their image compression instead, to get rid of the message – which I find a totally unreasonable suggestion, as Imagify is a better system with more functionality.

    I can understand the message when features are turned on and they conflict with other plugins, but in this case I’ve turned this feature off so there is no conflict. I should be able to close the message and never see it again. It doesn’t look good when clients log in and see what looks like an error message on all the admin pages.

    Still, I’m confident Siteground will deal with this. At least, I hope so!

    Same with me. In addition, the messages e.g. “GZIP Compression Enabled” appear to the right of the screen and I can’t get rid of them either.

    Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    @jetxpert can I get your ticket ID so I can reproduce the issue. Once you close that message it should never apear again.

    In addition to that, we disable our functionality and show you a message, not other plugins.

    I expect an update later today with everything reported overnight fixed but still, I would love to get more info so I can recreate. That’s definitelly a bug / issue with other plugin and not something by design.

    It keeps appearing at every page load/reload. Its still shows same after 5.03

    I dont want to use those caching its pathetic compared to my Autoptimize plugin. My site speed tanked from 2.3s to 4.5

    Please update the plugin or give an option to disable this warnings again and again

    Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    @tatsat it is intended to show only once, that’s why there’s a close button next to the message. This behaviour is not intended. Could you give me your domain so I can look into what’s causing it?

    But its not working that way. I have tried closing it multiple times keeps appearing after page load. where can I send you the website url

    Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    Ignore my previous post. Found it!

    It will be fixed in 5.0.4 later today!

    Just mailed you

    Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    Got it, thanks and appreciate your assistance, it will be fixed in 5.0.4!

    Hope this is soon the admins are getting panicked with these warnings all the time

    Thanks Hristo for getting involved and looking into this. Its most appreciated.

    Aside from the issues, its a nice update to the plugin. Lots of new features making it rival more comprehensive cache plugins. The new UI is nice as well. Good work.

    • This reply was modified 7 months, 3 weeks ago by  ChromaDot.
    Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    OK, 5.0.4 is live and it should fix everything reported in this thread. Could you update and verify please?

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘SG Optimizer 5.X (Persistent Warning Message)’ is closed to new replies.