Support » Plugin: SG Optimizer » SG Optimizer 5.0.7 problem with Woocommerce

  • Resolved zzanna

    (@zzanna)


    Hi Hristo,
    After i update SG Optimizer to the latest version, all the orders in my site have as total: Zero.
    No contact details in the backed for the orders acquired.
    No email were sent to the client.
    After disabling SG Optimizer all works just fine.
    Any ideas on the problem?

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    Could you try disabling memcached?

    Can’t risk right now to experiment on live website, i let SG Optimizer disabled
    I’ll wait after christmas

    Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    It is a WooCommerce bug and the way they handle Memcached. I would advise to keep the plugin but disable Memcached. We will be contacting Woo developers and meanwhile trying to solve it from our end but it’s a bit difficult honestly.

    OK thanks a lot Hristo for the news.
    i’ll try this evening to reactivate the plugin but keep memcached disabled

    Just one question: is this a problem of the new SG Optimizer 5.0.x? Cause with version 4.0.7 and precedent, all were fine

    @hristo-sg — Please weigh in here if you can. People are being charged properly, right? Where is the 0 total appearing?

    @zzanna — Where are you seeing the total as 0 with memcached enabled? On the frontend when attempting to complete a purchase?

    Thanks…

    In the frontend and also in the beckend

    Hi Hristo,
    on another site with Woocommerce and WPML i discoverder that the new SG Optimizer plugin 5.0.8 slow down the loading of pages to 1 minute.
    Reverting to 4.0.7 solved all the problems.
    I think the new plugin need a litte tune up

    Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    Can I have your domain name please? There’s something strange going on with your website and I would like to troubleshoot it further.

    unbrandedmanchester

    (@unbrandedmanchester)

    Hi

    Just to add to this, but you’re mistaken with the fact that this is to do with the latest version of Woocommerce.

    We were experiencing similar issues on the last version of woocommerce with BOTH the new version of SG Optimiser and the previous version. In fact, things have only gotten worse with the new one when working with Woocommerce – including sending upwards of 60 emails when trying to issue a refund throught Stripe.

    Siteground, why have you released a plugin that isn’t fit for purpose? Its no good saying its a bit difficult to resolve the issue but then leaving the plugin open for anyone to install, at the very least, pull the Memcache feature or TELL US NOT TO USE IT ON WOOCOMMERCE!

    The new plugin also slow down greatly the backend of wordpress.
    Reverting to 4.0.7 all is back to normal

    Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    If you notice such issues, just disable Memcached until we update it with fixes for your plugin. We’re working on that case and talking with WooCommerce developers but it will take some time.

    @hristo: The new plugin slow down the backend regardless of presence of Woocommerce

    If it doesn’t work with WooCommerce and you are aware, a) why have you published?and b) why are you not informing people?

    Seriously! Email to your customers right away, or update the blog post telling people to upgrade. I would hate to think anyone else gets caught out by this.

    I disabled memcached but potentially already lost my high value client! I would understand if this mistake was made by 3rd party devs but you are a hosting company and are encouraging people to use this plugin:

    https://www.siteground.com/blog/sg-optimizer-new-version/

    If they are on WooCommerce and they trusted you, the same thing could happen to them. This hit a major retail client for me during the Christmas rush.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘SG Optimizer 5.0.7 problem with Woocommerce’ is closed to new replies.