Support » Plugins and Hacks » [Resolved] SFC-new won't auto publish to fan page

[Resolved] SFC-new won't auto publish to fan page

  • I was wondering if the sfc-new version from svn has any unfinished bits which would affect auto-posting to a fan page?

    I already have an existing page, so posting to that works best.

    If I use the trunk version (the old SFC) it is incompatible with bbPress plugin (when the Like button is active). But it auto posts to my fan page perfectly

    So I upgraded to the new-sfc version out of svn, and that one is compatible with bbPress with the Like button active. So that takes care of one problem. But now the auto post doesn’t work.

    All of the authorizations are good

    User ID and Access Token found! Automatic profile publishing is ready to go!
    Application Access Token found! Automatic application wall publishing is ready to go!
    Fan Page Access Token found! Automatic fan page publishing is ready to go!

    And I’ve saved the page afterwords, but no luck with publishing.

    Any ideas what changed, what causes the old version to post, but not the new?

    Thanks very much!!

Viewing 7 replies - 1 through 7 (of 7 total)
  • Auto-publish should be working fine, haven’t had any reports of that breaking. Seems to work for me.

    Manual publish is indeed borked:

    This is a problem nobody but FB themselves can fix.

    Hmm… I wonder what’s up on my end?

    If I switch back to the .25 version or whatever is in trunk, autopost works fine

    But moving to the sfc-new version, auto posting does not work, even though all the settings are good, and all authorizations are in place

    The new auto-publish is sending to the Graph API. I’ll do some testing, see if I can figure it out.

    Found it. It’s the action links. Facebook doesn’t like ’em for some reason. It’s giving me back “The post’s action links must be valid URLs.” on a testing site I set up. The version I’m using doesn’t use action links.

    I’ll figure out the problem and push a fix.


    Facebook wants the action links double-encoded for some reason. Adding a json_encode around that array of action links fixed the issue.

    Fix committed to the branch. Also committed a change eliminating the need for the API key, since it’s not used anymore by FB’s new code.

    rock and freakin roll!

    I’ll toss it up on VoodooPress when I get home, and report back!

    Much appreciate the effort! (I’m pretty sure I owe you a beer or 2 by now! I should probably hit up that link on your site come payday)

    That took care of it! All is tested and functioning, thanks very much!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] SFC-new won't auto publish to fan page’ is closed to new replies.